Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I was copying files from SD cards, but at some point they stopped auto-mounting. Didn't notice any errors. I can still mount by right-clicking the appropriate file in /dev in Konqueror.

UPDATE: Slight correction. The drives never automounted, but I've stopped getting the notification that a drive is plugged in.

What processes should I be checking? Something in Device Actions?

I'm using Kubuntu 10.04

share|improve this question
add comment

5 Answers

up vote 1 down vote accepted

To enable automount: Right click the Device Notifier plasmoid and go to Device Notifier Settings. Click "Automounting" in the pane on the left, and then hit the checkbox to enable it.

To check that new devices are recognised:

tail -f /var/log/dmesg

Did you by any chance upgrade to KDE SC 4.5?

EDIT: Oh, in that case, right click on the tray and go to System Tray Settings, then check the box that tells the Device Notifier to be present in it.

share|improve this answer
    
Still on KDE 4.4.2. My actual problem is not getting the Device Notifier at all. Wondering if I should re-submit my question. –  steevc Aug 13 '10 at 9:46
    
As easy as just enabling Device Notifier. Wonder why I lost it. Thanks –  steevc Aug 16 '10 at 19:05
add comment

Check out system setting's removable devices section and see if auto-mounting is enabled, I think the default is NOT to automount removable media - access/actions are done through the Device Notifier normally. You can edit various settings and devices from there

share|improve this answer
add comment

You can enable mount your pen drive/ pen drive is detecting automatically by ubuntu 11.10. just go to disk utility and format it.

restart your system. You will get your pen drive option in HOME folder.

share|improve this answer
add comment

I go to Favorites, System Settings, Removable Drives (near the bottom under Hardware) to check the box for that device. It is easier for a GUI user than typing commands and hoping that you typed correctly.

share|improve this answer
add comment

Automounting is done by udev (/sbin/udevd), so that would be the first thing I'd check.

share|improve this answer
    
udevd is running. 3 instances in fact. Is that one per logged-in user? Not seeing any error in any log files in /var/log –  steevc Aug 7 '10 at 21:18
    
Automounting is not done by udev. –  Li Lo Aug 7 '10 at 21:21
2  
udev is responsible for device recognition and calling hal events (wich in turn calls a dbus event). But not the mounting it self! –  Source Lab Aug 12 '10 at 7:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.