Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just restarted my server and now when I boot up one of my Ubuntu 11.04 Server instances I am greeted with errors. It doesn't boot up. Screenshot of boot up screen

I am pretty sure this is not a hardware error as I have other servers that are successfully booting up. In case it is relevant, all of these machines are running on a Proxmox server.

I tried running the recovery tool but I am not having any luck solving anything. When I try to mount /dev/sda1 in recovery it looks like there is nothing but the kernel on the disk. What can I try?? Needless to say I really don't want to reinstall Ubuntu and wipe my disk clean.

Thanks!

Edit: When I try to mount the root partition and go in the target folder I only get: Target

It looks like I am supposed to mount the /dev/WEBAPPS-LOCAL/root drive to the /target folder, but when I do I get a "Segmentation fault" error.

share|improve this question
add comment

2 Answers

OK, first of all this appears to be a KVM running on Proxmox, right?

/dev/sda1 appears to be a separate boot partition (/boot). You are probably looking to set /dev/sda2 as the target in recovery mode, which should contain /, /sbin, /proc etc. where the problem lies (can't find init).

Based on the segfaults you get, it looks like the root ilesystem on /dev/sda2 may be corrupted. Please run sudo fsck on it; you may have to attach an Ubuntu LiveCD ISO to your KVM and boot from that to be able to do so.

A screenshot of the full text preceding the segmentation fault on boot up (see cutoff portion in first screenshot) might also be helpful.

share|improve this answer
    
Thank you for your response. I figured it out and posted my response below. I appreciate your help! –  skaz Jul 10 '12 at 0:55
    
@skaz: please consider upvoting then answer and accepting either it or your own so that the question is "closed". Thanks! :) –  izx Jul 10 '12 at 1:00
    
Will do - need to wait two days first :( –  skaz Jul 10 '12 at 2:23
    
Sorry, I forget that -- haven't really asked many questions on AU :) –  izx Jul 10 '12 at 2:24
add comment

It looks like my disk was corrupted. The root disk in the Proxmox environment looks like it is: /dev/WEBAPPS-LOCAL/root.

When I ran the Live CD I could not mount this target as I got a seg fault. I couldn't run fsck after I tried this: it said I couldn't fsck something that was mounted. It must have been in some intermittent state.

I reran the LiveCD again, went into Recovery mode and this time attempted to run no disks as root. Then in the shell I ran fsck against /dev/WEBAPPS-LOCAL/root and it made some fixes. Then I was able to boot into the server correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.