Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 11.04 on a tablet with a Core i5-2557M processor. When doing processing intensive tasks the CPU is forcibly under-clocked to 800MHz (instead of the normal base of 1.7GHz.) The CPU temperature is around 75 C.

I have disabled CPU scaling (set governor to performance) but this seems to have no effect. I would like to either modify the behavior so that the throttling happens at 95 C or I would like to disable it altogether. Changing the min/max frequency as root using cpufreq works until the temperature rises and then it ceases to work, ignoring a minimum frequency above the 800MHz.

On Windows 7 there is a 3rd party utility that can do this (ThrottleStop).

Thank you.

share|improve this question
Put it in a light breeze; Running it hot is a bad idea, you will shorten its life. – richard Jul 9 '12 at 21:19

The throttling is defined in the firmware (BIOS) and the kernel is just following the orders to do what is right. If you ignore throttling and the CPU hits Tjmax your CPU will shutdown automatically. I suspect the machine is designed this way so you don't see blue smoke appear out of the machine too frequently.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.