Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I feel like this should be a no brainer, but I just can't seem to figure it out. I am running Ubuntu Server 10.04 as a virtual machine in VMWare Fusion. I am simply trying to get there to be some sound that comes out of my laptop speakers. I have installed Alsa and MOC (followed these instructions, and it worked fine). Especially using MOC, I can see that the song (an MP3) is playing, but I am not getting any sound out.

lspci | grep audio gives me: 02:02.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 02)

This doesn't seem like it should be that big of a deal, but I just can't seem to make it work. Any ideas?

share|improve this question
    
I am having the same issue with a copy of Ubuntu server on a computer where it is the only OS running. Using alsamixer everything is turned up, not getting any sound out. Even if you don't know the answer, is there anyone who has gotten sound to work on Ubuntu Server in any form? –  emilyk Jul 20 '12 at 18:19
    
I assume you have either installed ubuntu-restricted-extras or the lame package for mp3 support. Can you confirm? –  user88502 Sep 9 '12 at 13:11
add comment

2 Answers

Did you check to make sure sound is enabled in the VM? I use VMware Player instead and I'm not sure of the differences but there's a bar along the bottom-right that allow me to control the shared devices.

share|improve this answer
    
The sound card is connected and I haven't had any issues with other operating systems that I've installed playing sound (Ubuntu Desktop, Windows 7, Haiku). So I am pretty sure that it is enabled. –  emilyk Jul 9 '12 at 20:47
    
Yes, I agree, perhaps you should install VMware Tools for Fusion: Installing VMware Tools in a Fusion virtual machine running Windows –  swift Jul 9 '12 at 20:55
    
More concretely this link: Installing VMware Tools in an Ubuntu virtual machine ... Look for note: "Whenever the Linux kernel (operating system) is updated, VMware Tools needs to be reinstalled." So, if you install sound server, obviously you should reinstall VMware Tools also. –  swift Jul 9 '12 at 21:01
    
Reinstalled it...didn't help with the sound problem at all. –  emilyk Jul 9 '12 at 21:21
    
I have the same problem, on an actual server. –  Jakob Weisblat Jul 14 '12 at 3:19
show 1 more comment

I was able to get this working on a physical server over the weekend and did a writeup on my blog: http://darylwinsinger.blogspot.com/2012/09/installing-mpd-on-ubuntu-server.html

Basically, you need to install alsa, lame (for mp3 support if needed), and mpd. This can be done via sudo apt-get install alsa lame mpd. Configure your volume levels using sudo alsamixer, configure mpd with what folder the music is in via the music_directory in /etc/mpd.conf (make sure the mpd user can read that folder, its subfolders, and all the files contained therein as noted in the mpd config file), and configure mpd to listen on on the correct IP address via the bind_to_address in /etc/mpd.conf (or just comment that line which will cause mpd to default to "any"). Assuming all of those steps have been completed, you can narrow the issue down to an issue with the VM playing sound through VMware. "swift" already provided a link on how to install the VMware tools as a comment on Corey's answer.

Note: I used VirtualBox for my testing before rolling this out to the physical server as the config and management may be a little limited in VirtualBox, but is easier to set up each new VM.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.