Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the launchpad the ppa and the project configured but when I try to quickly submitubuntu it aborts. I tried to create the Debian package with quickly package --extras and it worked and with the 'quickly package' it worked too, I don't understand...

This is my submission to the app showdown...

The error:

glink@glink:~/mydev/SRC/src-install$ quickly submitubuntu 
Obter definições do Launchpad
bzr: ERROR: The user fernandofreamunde has not registered any SSH keys with Launchpad.
See <https://launchpad.net/people/+me>
Launchpad connection is ok
.............Ubuntu packaging created in debian/
...ERROR: quickly can't release: can't push to launchpad.
ERRO: O comando submitubuntu falhou
A abortar
glink@glink:~/mydev/SRC/src-install$
share|improve this question
    
For future reference, this would have helped debugging: askubuntu.com/questions/160774/… –  David Planella Jul 17 '12 at 7:28

1 Answer 1

up vote 3 down vote accepted

You need to create a SSH key and upload it into Launchpad.

Instructions:

Step 1: Install OpenSSH. On Ubuntu, you can install OpenSSH by opening your terminal and typing:

sudo apt-get install openssh-client 

Step 2: Once OpenSSH is installed, stay in the terminal and type:

ssh-keygen -t rsa

Step 3: When prompted, press Enter to accept the default file name for your key.

Step 4: Next, enter then confirm a password to protect your SSH key. Your key pair is stored in ~/.ssh/ as id_rsa.pub (public key) and id_rsa (private key)

Now you need to upload the public portion of your SSH key to Launchpad.

Source: Launchpad - https://help.launchpad.net/YourAccount/CreatingAnSSHKeyPair
share|improve this answer
    
thank you so much that worked, now im nervous to see the results :) because some one told me that i was already late although the countdown is still active :/ –  Fernando Andrade Jul 9 '12 at 19:02
    
Down to the last minute! Good job for getting something submitted! –  xlukasx Jul 10 '12 at 0:30
    
thanks :) now in the launchpad it don't build, apparently it is a quickly bug trying the proposed fix for it :) –  Fernando Andrade Jul 11 '12 at 14:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.