Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to Ubuntu 10.10. When Firefox or my photo album is open the sound in Rhythmbox cracks and cuts like someone scratching a disc with a needle. On its own or with Evolution open the sound is fluid and entirely undisturbed. How can I fix this?

share|improve this question
    
...sorry, "running." –  Anthony Burman Dec 4 '10 at 13:39
    
sounds to me like you have a system that is fighting for resources (especially CPU wise). Pulseaudio can cause some problems under such circumstances. Can you post some more information in your question, like your CPU, Memory and Sound Devices? –  RolandiXor Dec 4 '10 at 13:58
    
Oh dear, thanks. How do I find that info? I only know that the CPU produces a graph but I don't think snapshots can be posted. System monitor produces graph readouts. Do I write them down and post them? –  Anthony Burman Dec 4 '10 at 14:07
    
The problem only started when I upgraded to 10.10. Until then it was fine. –  Anthony Burman Dec 4 '10 at 14:45
    
This is a bug. Please file one using ubuntu-bug pulseaudio, then close this question. –  Daniel T Chen Dec 4 '10 at 22:22

2 Answers 2

Not running the pulseaudio equalizer are you?? (http://ubuntuforums.org/showthread.php?t=789578)

I found many of the presets were just too much for the soundcard, levels or the headphones I was using and crackled insistantly.

share|improve this answer

A quick bandage (but not a fix) to try is this (From Fedora Wiki)

If the glitch-free PulseAudio exhibits glitches that cannot be fixed in time for F10, we can just revert to the last 'traditional' PulseAudio release.

To limit the problems with Alsa drivers, there is now a switch "tsched=0" for the module-hal-detect module which will disabled glitch-free mode for all sound cards globally. To use this edit /etc/pulse/default.pa and append "tsched=0" to the line "load-module module-hal-detect" NOTE: The line is now "load-module module-udev-detect tsched=0"

To edit the file mentioned, press alt+f2 and type:

gksudo gedit /etc/pulse/default.pa

To report a bug go to here to learn more: https://help.ubuntu.com/community/ReportingBugs

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.