Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is how I installed weka 3.6.6:

sudo apt-get install weka

On 12.04 every time I open weka it starts in the second workspace. If I move it to workspace #1, all the new windows it opens are in workspace #2. If I try and work in the 2nd workspace, new windows are opened in the 1st. There's no way for me to avoid being hassled by weka.

If I use MyUnity to have only 1x1 workspaces, weka opens, I can tell because it appears in the launcher. but I guess it's in an invisible workspace as I can't see the window.

I tried running some arbitrary Game of Life jar using java -jar GameOfLife.jar and it opened in the current workspace. No problem.

I tried downloading weka 3.7.6 and running weka.jar directly and it had the original problem too.

This is the contents of /usr/bin/weka if it helps.

#!/bin/bash

. /usr/lib/java-wrappers/java-wrappers.sh

# default options
CLASS="weka.gui.GUIChooser"
MEMORY="512m"
GUI=""

function usage()
{
   echo 
   echo "usage: ${0##*/} [-m|--memory <memory>] [-h|--help] [-c|--classname <classname>] [options]"
   echo
   echo "Starts the Weka Machine Learning Workbench."
   echo 
   echo " -h,--help        this help"
   echo
   echo " -c,--class <class>"
   echo "             start using an alternative class if no classname is"
   echo "             given, then '$CLASS' is used by default."
   echo 
   echo " -g,--gui <MDI|SDI>"
   echo "            start weka gui as MDI or SDI"
   echo
   echo " -m,--memory <memory>"
   echo "             the amount of memory to use for the Java Virtual Machine"
   echo "             default: 256m (= 256MB)"
   echo 
}


TEMP=`getopt -o hc:m:g: --long help,class:,memory:,gui: -n 'weka' -- "$@"`

if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
eval set -- "$TEMP"

while true ; do
    case "$1" in
        -c|--class) CLASS="$2" ; shift 2 ;;
        -m|--memory) MEMORY="$2" ; shift 2 ;;
        -g|--gui) GUI="-gui $2" ; shift 2 ;;
        -h|--help) usage ; exit 1 ;;
        --) shift ; break ;;
        *) usage ; exit 1 ;;
    esac
done

find_java_runtime openjdk6 sun6 || \
    ( echo "$0: Java not found, aborting." >&2 && exit 1 )
find_jars weka.jar
JAVA_ARGS=-Xmx$MEMORY run_java $CLASS $GUI $@

I realize this may sound like a "weka mailing list" question, but the fact that MyUnity 1x1 makes weka completely invisible is probably a unity bug...

share|improve this question

closed as off topic by Eliah Kagan, nitstorm, jokerdino, izx, Jorge Castro Aug 15 '12 at 0:13

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have no clue why, but I have the same problem in precise. Until seeing your question I had no idea weka was successfully starting up at all - it just seemed to hang from the command line.... Thanks. FWIW, I'm using two monitors. I note some odd problems with google chrome opening up in the wrong monitor at times also.... –  nealmcb Aug 11 '12 at 0:41
2  
I opened this bug in Unity: bugs.launchpad.net/unity/+bug/1035520 –  nealmcb Aug 11 '12 at 1:00
1  
This seems to be a bug in compiz related to either multi-monitor setups (Bug #874146 “New windows open on the wrong monitor” : Bugs : Compiz Core), or the use of modal windows (Bug #754508 “Modal dialogs don't appear on the workspace of thei...” : Bugs : Compiz). So this should probably be closed here in askubuntu since it is a bug and thus out-of-scope. –  nealmcb Aug 14 '12 at 2:45
    
How do I go about closing the question without an answer? If you convert the comment with all the bug links into an answer then I can accept that "solution". –  ubershmekel Aug 14 '12 at 8:24
add comment

1 Answer 1

up vote 0 down vote accepted

This seems to be a bug in compiz related to either

or

So this question should probably be closed as "off topic" here in askubuntu since it is a bug and thus out-of-scope according to the FAQ.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.