Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to disable Touchpad?

I'm looking for a way to permanently disable the touchpad in Ubuntu 12.04 (my computer is a Lenovo Thinkpad Edge on which it isn't possible to disable it in the BIOS).

I tried the applications GPointingDeviceSettings and synaptiks 0.8.1 as well as the applets touchpad-indicator and Jupiter. None of these does the trick of disabling the touchpad permanently.

Jupiter comes closest - it remembers that I have disabled the touchpad after restart - but when I login after the computer has been in suspend mode, the touchpad is enabled again.

Can anyone help me in disabling the touchpad possibly at a lower level so it won't in any way be enabled unless I choose to enable it?

I'm totally new to linux so a detailed explanation would be much appreciated ...

The links, so far, doesn't address my question. I have no problem turning the touchpad off and making it stay off after reboot but when I login after the computer has been in an altered power mode it's on again. Isn't there a way to permanently disable a device like touchpad?

share|improve this question

marked as duplicate by Marco Ceppi Oct 22 '12 at 6:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Why would you want to permanently disable touchpad on laptop? –  Flint Jul 9 '12 at 13:38
    
Possible answers to similar question askubuntu.com/questions/65951/how-to-disable-touchpad –  CoalaWeb Jul 9 '12 at 14:39
    
I have disabled it in the BIOS. That is permanent for any OS you choose to install. –  Ed Manet Jul 19 '12 at 17:17

4 Answers 4

You can find a tutorial with screenshots on how to disable your touchpad here.

There was an ask ubuntu article about this here.

One reason you might want to disable your touchpad is because you have a mouse connected to the laptop, so do not need to use the touchpad. The touchpad sometimes accidentally gets used, moving your cursor around the screen to a place you don't want it to be.

share|improve this answer

Here is what finally solved the problem (posted by myself): gpointing-device-settings lost on reboot

What had me (a linux newbie) confused was the difference between gconf and dconf. In this regard this was helpfull: When to use gconf vs dconf?

share|improve this answer
    
How do I flag this as the right answer (read somewhere that answering your own question - if you figure it out yourself - is recommended) ... –  user76766 Jul 19 '12 at 17:08
1  
When you answer your own question, you can accept your own answer starting 2 days after posting it. –  Eliah Kagan Jul 19 '12 at 20:45

The command

synclient TouchpadOff=1

is what I use (change 1 to 0 to re-enable).

share|improve this answer
1  
This does not work for me (Thinkpad x230, Ubuntu 13.10). After setting TouchpadOff=0 the setting is reset to TouchpadOff=2 as soon as I touch the touchpad. –  Andreas J. Dec 2 '13 at 2:41
    
@AndreasJ. Same happened to me. As soon as I set TouchpadOff=1, it would change it to TouchpadOff=0 and then to TouchpadOff=1. Very odd! I'm using Ubuntu 12 LTS, on a Latitude E6510... –  Swivelgames Jul 23 at 18:40

I installed Pointing Device (package: gpointing-device-settings) from the store and it did disable my touchpad.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.