Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The option to disable the touchpad while typing does not work on my Samsung RC512 with an Elantech touchpad and I enjoy two-finger scroll and middle-click emulation with two fingers too much to disable tapping the touchpad. When I type the cursor will jump around because I'll hit the touchpad with my palm. How can I disable one-finger tapping but keep multi-finger tapping?

share|improve this question
add comment

2 Answers

synclient TapButton1=0
  • TapButton1 means 1-finger tap.
  • 0 means do nothing.
share|improve this answer
    
Is this persisted across sessions? –  fmoo Jul 17 '13 at 0:33
add comment

xinput will allow you to manipulate the properties of human interface devices. It will also show you what human interface devices are there, and some parameters for manipulating them, such as their name and id.

xinput

Shows you a list of devices, I have an Elantech touchpad that shows up as ETPS/2 Elantech Touchpad id=12 [slave pointer (2)]. You should run the command to see the same, but I'll phrase my answer using the output that I see.

xinput list-props 12

Shows me the available properties for item id 12, which you can see decriptions for in the Synaptics Man Page.

There looks like there could be multiple strategies for doing what you're looking for, but the property Synaptics Tap Action (327) looks promising and the man page says to set this to 0 to disable.

 xinput set-prop 12 327 0

where 12 is the device's id as shown by xinput and 327 is the property number as seen in xinput list-props 12

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.