Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried installing both with Wubi and by booting from a USB drive.

After I tried both it was the same. Ubuntu tried to login, but after a while, a weird pattern with squarely shapes appeared. At one point, after using recovery mode and then the low graphics one (I don't remember how it was called exactly) I managed to get in. It still didn't display at correct resolution, and the mouse was invisible at times. However, after rebooting once, because i tried downloading the Nvidia drivers, I didn't manage to get in again, so I have the same problem...

I have no idea what to try to become unstuck. The main problem is that after the login, ubuntu crashes, with a screen full of randomly coloured squares. Should I just give up?

share|improve this question
Definitely shouldn't give up. Have you tried installing the Nvidia drivers using the "Additional Drivers" tool, or the Nvidia website? Also what is the model of your Nvidia card? – Goddard Jul 9 '12 at 5:04

Certain classes of NVidia cards are notoriously poor with Linux. Especially when using the open source Nouveau drivers. So you need to say what card it is.

I have a 7600GS. This card NEVER works with the open source NVidia drivers, it gives the issues you mention. The trick is to either switch to VESA generic drivers until you can install NVidia's own drivers or boot to a command line only, then install the NVidia drivers and start X or reboot.

The BinaryDriverHowto/Nvidia page in the Ubuntu documentation has further information about swapping drivers including how to do this from a command line using the jockey-text command.

share|improve this answer
Thanks, I tried reinstalling nvidia drivers as you said. Since I couldn't get in, I reinstalled wubi, and there was a window of opportunity where I could actually use the graphical interface. I downloaded the drivers and now everything works perfectly. I was just scared when I couldn't even use sudo commands, but when I got in the gui, I could open a terminal and just download. – jimbo Jul 9 '12 at 12:46
OK, glad you got it. Linux is great when it works first time but a bit of a nightmare when it doesn't! – Julian Knight Jul 9 '12 at 13:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.