Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do i get rid of the last panel in Classic Gnome session in 12.04? I couldn't find any way for Precise.

share|improve this question
1  
What is the "last" Gnome Panel, out of curiosity? –  izx Jul 9 '12 at 0:46
    
when you have more than one panel, e.g one at the top of the screen and one at the bottom, the panel's right click menu allows you to delete one panel, but not the last one, i.e, there has to be at least one panel –  thelaststud Jul 10 '12 at 6:57
add comment

1 Answer 1

up vote 1 down vote accepted

This worked in 11.04 so it's worth a try. Open up classic-gnome.session the example below uses nano to edit the file.

sudo nano /usr/share/gnome-session/sessions/classic-gnome.session

and change these two lines

Required=windowmanager;panel;filemanager;
Required-panel=gnome-panel

to this

Required=windowmanager;filemanager;
#Required-panel=gnome-panel

Then log out and back in.

Reference Links:

http://www.torypages.com/blog/?p=819

http://ubuntuforums.org/showthread.php?t=1740597

share|improve this answer
    
I see this marked as answered but this does not apply to 12.04. The lines stated above are not present in the classic-gnome.session file. [GNOME Session] Name=GNOME Classic RequiredComponents=gnome-panel;gnome-settings-daemon; RequiredProviders=windowmanager; DefaultProvider-windowmanager=gnome-wm DefaultProvider-notifications=notify-osd IsRunnableHelper=/usr/lib/gnome-session/gnome-session-check-accelerated FallbackSession=gnome-fallback DesktopName=GNOME –  Themiddaysun Oct 18 '12 at 17:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.