Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Absinthe 2.0.4 on Ubuntu 11.10 on a netbook. When I try to run the install file, this keeps on happening:

rafael@RafLaptop:~/Desktop/absinthe-linux-2.0.4$ ./absinthe.x86 ./absinthe.x86: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by ./absinthe.x86)

Do I need to upgrade GLIBC? If so, how do I do that? Since I'm on a netbook I can't use a LiveCD so I wanted to know if there was a way I could fix this issue without reinstalling my whole OS.

Any explanations about what GLIBC is exactly would be great too since this is a learning experience for me. I know that GLIBC is a part of libc.so.6 and so I tried to run sudo apt-get install libc.so.6 but was told that it was up to date. But GLIBC isn't?

I hope this articulates my problem well, if there are any pieces of missing info or questions to clarity my question, please let me know!

~-~

EDIT/UPDATE:

So after some help on the AskUbuntu chat room from user izx, I have gathered the following information/understanding:

-I need to run this program with Ubuntu 12.04 or recompile it from source -Upgrading libc on Oneiric to 2.15 while possible, is not an easy task and is not officially supported.

share|improve this question
    
I added an answer expanding slightly on our discussion in chat, and suggesting that you use a 12.04 LiveUSB to solve this easily and without wasting time. –  izx Jul 9 '12 at 1:48
add comment

2 Answers

up vote 2 down vote accepted

Note: Absinthe is the iOS 5.1 jailbreak tool.

  • As tijybba has explained, libc (same as GLIBC) is the core library required by every single program on your system, including the kernel. For these reasons, it isn't really upgraded very often during the lifetime of a non-LTS release, if at all.
  • libc 2.15 shipped by default with Ubuntu 12.04, while Oneiric/11.10 stops at 2.14. No updates to 2.15 are available; while you can certainly download and compile 2.15 yourself, it's relatively complicated and can easily break your system (because it's such a core library).
  • For most programs, you could solve this problem by building them from source (where the currently available libc 2.14 would be used), but you cannot do this for Absinthe since it looks like they don't make source code available.
  • There are ways to make a binary use a specific version or set of libraries (google LD_PRELOAD and LD_LIBRARY_PATH), but they won't work here -- put simply -- because (again!) of how crucial libc is (I tried on 11.10).

Your best option then, is to just create a 12.04 Live-USB, boot from it, install Absinthe, connect your iPhone/iPod/iPad, and jailbreak away.

share|improve this answer
add comment

The required 2.15 version is not available for Ubuntu 11.10 as here and here, you will need Ubuntu 12.04 Precise also from here for that.

Either you will have to build it from source ( not recommended).

libc is the C library; basically, it contains all of the system functions that most (if not all) programs need to run on Linux. It's similar to a combination of dos.library and exec.library on Amigas, but it also contains a lot of things that are in the C runtime library (like, for example, ixemul.library or the .lib files included with SAS/C and other compilers for AmigaOS).

You can find its Official GNU page here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.