Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Me Menu on the top panel does not let me type a status to post to Gwibber or Pidgin. It simply is a grayed-out box that says "Post message..." I cannot type into it. Also, the status selector only works (not grayed out) when Pidgin is logged in; I cannot go from offline to available.

I already tried re-installing indicator-session, indicator-applet-session, indicator-me, gwibber, and gwibber-service, and removing and re-adding the applet.

Edit: Here's the console output when running Gwibber. It throws some errors, but none seem to be relevant.

** (gwibber:7611): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (gwibber:7611): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (gwibber:7611): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags' /usr/bin/gwibber:73: GtkWarning: IA__gtk_container_add: assertion `GTK_IS_CONTAINER (container)' failed  gtk.main()
share|improve this question
    
AFAIK the status selector will work only after logging in to Pidgin.By normal it's greyed out. –  karthick87 Dec 4 '10 at 7:01

1 Answer 1

Also, the status selector only works (not grayed out) when Pidgin is logged in; I cannot go from offline to available.

I think this is a "feature" -- you need first start an IM client to control it from MeMenu.

Same with Gwibber -- you need to start Gwibber manually (ar add it to startup application) and then you'll be able to write messages...

Editor: Problem with switching back to available after setting "offline" is known bug -- https://bugs.launchpad.net/indicator-me/+bug/550824

share|improve this answer
    
When Pidgin is open but set to offline, the status selector doesn't work, but it activates when I go available. –  zacharyliu Dec 4 '10 at 7:53
    
On the other hand, the status box just doesn't work at all, even if Gwibber is opened. gwibber-service is running at startup. –  zacharyliu Dec 4 '10 at 7:54
    
Yes, the offline→avaialble "thing" is known bug -- bugs.launchpad.net/indicator-me/+bug/550824 –  Vojtech Trefny Dec 4 '10 at 8:10
    
Maybe there's a little misunderstooding -- the "Post message" box is not for settings status text in Pidgin/Empathy -- it's for sending messages via Gwibber to services like Twitter, Identi.ca or Facebook... –  Vojtech Trefny Dec 4 '10 at 8:12
    
Okay, I understand the Pidgin/Empathy<->Me Menu limitations now. –  zacharyliu Dec 4 '10 at 16:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.