Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed my Ubuntu 12.04 desktop after a dependency loop hell.

After I re-installed the Unity panel shows all application icons whenever the app is loaded.

For example I can now always see VMware and X-Chat where on every previous install these icons never showed no matter how much I wanted them too sometimes.

These indicators are starting to fill up my taskbar and was wondering how to make them go away.

For example I want Thunderbird, Empathy and X-Chat to be able to be closed to the messaging menu like they did in all my other previous installs.

Also I have X-Chat indicator installed but it will not allow me to close to messaging menu - I have to have the indicator icon enabled in order to close it.

Any assistance in these issues would be greatly appreciated.

share|improve this question

If by unity taskbar, you mean the unity launcher on the left side of the screen, you may remove any icon by right clicking it and selecting remove from launcher.

In 12.04 the default behaviour is to automatically add icons for newly installed app's to the launcher.
In 11.10 you had to tell software centre to do that or right click the icon of an open program and select keep in launcher.

Applications icon's can generally be removed from the top panel using the preferences menu of the application or utility

share|improve this answer
No not the launcher sorry I meant the Unity panel on top – shaneo Jul 8 '12 at 15:15
Could you post a screenshot by editing your original question. You can use the 'PRTSC' key or 'screenshot' app to take a screenshot. Applications icon's can generally be removed from the top panel using the preferences menu of the app or utility. – Fernhill Linux Project Jul 8 '12 at 15:22
I would take a screenshot to show you but all of a sudden the applications started doing what I wanted them to. I didn't touch anything so idk what happened. But for now it seems to be resolved I will keep this question open though in case it happens again. – shaneo Jul 8 '12 at 17:23
Perhaps an update fixed a bug? Anyway glad to hear the problem is solved for now .... :o) – Fernhill Linux Project Jul 8 '12 at 17:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.