Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a big problem with packing my quickly application for the Ubuntu App Showdown. When I try to package or submit my application, I get some warnings:

quickly package --verbose
........
----------------------------------
WARNING: syntax errors in facebook/FacebookWindow.py: encoding declaration in
Unicode string (FacebookWindow.py, line 0)
WARNING: the following files are not recognized by DistUtilsExtra.auto:
  AUTHORS~
  facebook/AboutFacebookDialog.py~
  facebook/FacebookWindow.py~
  facebook/PreferencesFacebookDialog.py~
  facebook/__init__.py~
  facebook_lib/AboutDialog.py~
  facebook_lib/Builder.py~
  facebook_lib/PreferencesDialog.py~
  facebook_lib/Window.py~
  facebook_lib/__init__.py~
  facebook_lib/facebookconfig.py~
  facebook_lib/helpers.py~
  setup.py~
----------------------------------
An error has occurred when creating debian packaging
ERROR: can't create or update ubuntu package
ERROR: package command failed
Aborting

What does the second warning mean? How do I solve those warnings? I want to submit my app to the Ubuntu App developer Showdown into my PPA and it doesn't work.

Thanks for any answer.

share|improve this question
2  
Please post the output of quickly package --verbose when you are asking for support. –  Agmenor Jul 9 '12 at 15:05
1  
This was the output of 'quickly package --verbose'! –  slashcrack Jul 12 '12 at 14:00
add comment

3 Answers

up vote 4 down vote accepted

You are probably using a version of the python-distutils-extra package from the precise-proposed pocket in the archive, that is newer than the stable release and that it is known to cause trouble with the latest Quickly version.

Try to downgrade it by running the following command, and then re-run the Quickly packaging command:

sudo apt-get install python-distutils-extra=2.32-2
share|improve this answer
    
thank you very much! it works :) –  slashcrack Jul 9 '12 at 12:35
add comment

To get rid of the warnings, just delete all the files that are ending in "~". Those are back-up files created by your text editor whenever you save a file. It is safe to remove them if your app runs flawlessly when you do quickly run for example. The files ending in "~" are hidden files, so when you are in Nautilus, don't forget to hit Ctrl+H to see them.

share|improve this answer
add comment

I had the same problem, the output of quickly package --verbose was:

running install_egg_info
Writing /tmp/tmpzO_6QQ/dockremoteclient-0.9.egg-info
Traceback (most recent call last):
  File "/usr/bin/python-mkdebian", line 368, in <module>
    egg = get_egg_info()
  File "/usr/bin/python-mkdebian", line 35, in get_egg_info
    k, v = l.strip().split(': ', 1)
ValueError: need more than 1 value to unpack
An error has occurred when creating debian packaging
ERROR: can't create or update ubuntu package

The problem was that in the setup.py file I had written a long_description with a new line (\n), which is not good. I removed it and the problem was solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.