Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For a long time I've been unable to get updates due to a "repositories not found" error. Yesterday someone fixed this for me but after installing 94 days worth of updates my system wanted to restart.

It looks like it is booting normally but then it opens a terminal and asks for my login and password.

I had tried Ctrl+ Alt +F7 and startx to no avail.

Here is everything that appears on screen when I turn the computer on.

Ubuntu 10.04.4 LTS box-o-doom tty1
box-o-doom login:julian
last login: Sun Jul 8 10:28:02 BST tty1
Linux box-o-doom 2.6.32-41-generic-pae #91-Ubuntu SMP Wed Jun 13 12:00:09 UTC 20
12 i686 GNU/Linux
Ubuntu 10.04.4 LTS

Welcome to Ubuntu!


i then tried


which produced hundreds of lines all very similar to the first line reproduced here

[    9.453119] type=1505 audit1341742405.022:10):  operation="profile_replace"
pid=743 name="/usr/lib/connman/scripts/dhclient-script"

follwed by this at the end

[    9.475880]   alloc irq_desc for 27 on node-1
[    9.475883]   alloc kstat_irqs on node-1
[    9.475890]forcedeth 0000:00:07.0: irq27 for MSI/MSI-X
[    9.760031] hda_code:ALC662 rev1: BIOS auto-probing.
[   10.048095] input:HDA Digital PCBeep as /devices/pci 0000:00:05.o/inp
[   10.862278] ppdev: user-space parallel port driver
[   20.268018] eth0: no IPv6 routers present

results of startx lots of text scrolls off the screen and i have no way of reading it. but everything i can see is reproduced below

current version of pixman: 0.16.4
    Before reporting problems, check
    to make sure that you have the latest version
Markers: (--) probed, (**) from config file, (==) defult setting,
    (++) from command line, (!!) notice, (II) informational.
    (WW) Warning, (EE) error, (NI) not implemented, (??) unknown.
(==) log file: "/var/log/Xorg.0.log", Time: SUn Jul 8 12:02:23 2012
(==) using config file: "/etc/X11/xorg.conf"
(==)using config directory: "/usr/lib/X11/xorg.conf.d"
FATAL: Module nvidia not found.
(EE) NVIDIA: Failed to load the NVIDIA kernal module please check your
(EE) NVIDIA:     systems kernal log for aditional error messages.
(EE) Failed to load module "nvidia" (module specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

please consult the foundation support
for help
please also check the log files at "/var/log/" for aditional informati
 ddxSigGiveUp: Closing log
giving up
xinit:  No such file or directory (errno 2): unable to connect to X server
xinit:  No suck process (errno 3): server error
share|improve this question
Possible Duplicate:… – Mitch Jul 8 '12 at 10:07
@Mitch as advised in the answer you linked i tried dmesg will add results to original question – Jules Jul 8 '12 at 10:48
up vote 0 down vote accepted

As you can see from your startx output there seems to be a problem with your nvidia drivers:

FATAL: Module nvidia not found.
(EE) NVIDIA: Failed to load the NVIDIA kernal module please check your
(EE) NVIDIA:     systems kernal log for aditional error messages.
(EE) Failed to load module "nvidia" (module specific error, 0)
(EE) No drivers available.

(BTW, you can find the complete X log in /var/log/Xorg.0.log.)

First try to (re)install the drivers via

sudo apt-get install --reinstall nvidia-current

If startx still does not get you to the desktop now, I'd recommend editing your xserver configuration, e.g. via

sudo nano /etc/X11/xorg.conf

and commenting out the line for the nvidia driver, i.e. change

Section "Device"
    Driver      "nvidia"


Section "Device"
    # Driver        "nvidia"

and close nano with Ctrl+x and y to save the changes.

Then run startx again. Maybe this will start your desktop with a lower resolution than usual and you will not have any 3d acceleration, but you should at least get to the desktop again.

If so, uninstall / reinstall your nvidia drivers via the Additional drivers app in system settings and hopefully that'll fix it. You might have to edit xorg.conf again and uncomment the Driver line manually after reinstalling the driver.

share|improve this answer
nvidia drives re-install appeared to work, but then told me module build for the currently running kernal was skipped since the kernal source for this kernal does not seem to be installed startx didn't work. i'm about to try editing my xserver – Jules Jul 8 '12 at 13:46
the file etx/X11/xorg.conf seems empty and i'm confused by "commenting out" – Jules Jul 8 '12 at 13:53
worked out that etx was supposed to be etc and i have a GUI again! not sure if everything is working completely but a huge improvement! thank you! – Jules Jul 8 '12 at 14:01
@Jules yes it should have been etc, fixed that in my answer. Congrats on having the desktop back. The message from reinstalling the drivers you quoted above seems to indicate that there are some other packages missing. You should now try installing the drivers via the additional drivers applet in Ubuntu system settings, as I indicated above. Should work. – nem75 Jul 8 '12 at 14:48

To change the default from a command-line to GUI, try editing the GRUB configuration.

  1. Edit /etc/default/grub

    sudo nano /etc/default/grub
  2. Find this line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"


  3. Change it to

  4. Update the GRUB configuration

    sudo update-grub
share|improve this answer
i tried startx will add results to question – Jules Jul 8 '12 at 11:23
just tried sudo gedit /etc/default/grub asks for password then shows me (gedit:1454): Gtk-WARNING **:cannot open display: – Jules Jul 8 '12 at 11:46
-1 for telling someone who cannot boot to the desktop to use gedit – nem75 Jul 8 '12 at 13:10
@nem75 It was a typo... – Emerson Hsieh Jul 8 '12 at 14:27
@EmersonHsieh IMO nanp -> nano would be a typo, but not recommending a completely different program. Be that as it may your answer does not really have any relation to the question asked anyway, sorry. – nem75 Jul 8 '12 at 15:19

I have an issue and I wondered if anyone can please help we run this ubuntu10.4 Ltd sandbox2 as part of our main office server we use a stock control system called data flex I am having a real nightmare as our IT guy has left the company and I don't really know what I'm doing the stock package works on our main server but the link to our network pc's has gone and I kind of need a genious to help me out any takers as I don't have any stock control just weeks from Christmas and our business is grinding to a halt.

share|improve this answer
Best not to use answer a question when you would be better off using asking a new question. Your post is likely to be removed and not gain the attention it requires. – Graham Dec 8 '15 at 13:25
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review – waltinator Dec 8 '15 at 15:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.