Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a long time I've been unable to get updates due to a "repositories not found" error. Yesterday someone fixed this for me but after installing 94 days worth of updates my system wanted to restart.

It looks like it is booting normally but then it opens a terminal and asks for my login and password.

I had tried Ctrl+ Alt +F7 and startx to no avail.

Here is everything that appears on screen when I turn the computer on.

Ubuntu 10.04.4 LTS box-o-doom tty1
box-o-doom login:julian
password:
last login: Sun Jul 8 10:28:02 BST tty1
Linux box-o-doom 2.6.32-41-generic-pae #91-Ubuntu SMP Wed Jun 13 12:00:09 UTC 20
12 i686 GNU/Linux
Ubuntu 10.04.4 LTS

Welcome to Ubuntu!
*Documentation: http://help.ubuntu.com

julian@box-o-doom:~$_

i then tried

dmesg

which produced hundreds of lines all very similar to the first line reproduced here

[    9.453119] type=1505 audit1341742405.022:10):  operation="profile_replace"
pid=743 name="/usr/lib/connman/scripts/dhclient-script"

follwed by this at the end

[    9.475880]   alloc irq_desc for 27 on node-1
[    9.475883]   alloc kstat_irqs on node-1
[    9.475890]forcedeth 0000:00:07.0: irq27 for MSI/MSI-X
[    9.760031] hda_code:ALC662 rev1: BIOS auto-probing.
[   10.048095] input:HDA Digital PCBeep as /devices/pci 0000:00:05.o/inp
ut/input6
[   10.862278] ppdev: user-space parallel port driver
[   20.268018] eth0: no IPv6 routers present
julian@box-o-doom:~$_

results of startx lots of text scrolls off the screen and i have no way of reading it. but everything i can see is reproduced below

current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version
Markers: (--) probed, (**) from config file, (==) defult setting,
    (++) from command line, (!!) notice, (II) informational.
    (WW) Warning, (EE) error, (NI) not implemented, (??) unknown.
(==) log file: "/var/log/Xorg.0.log", Time: SUn Jul 8 12:02:23 2012
(==) using config file: "/etc/X11/xorg.conf"
(==)using config directory: "/usr/lib/X11/xorg.conf.d"
FATAL: Module nvidia not found.
(EE) NVIDIA: Failed to load the NVIDIA kernal module please check your
(EE) NVIDIA:     systems kernal log for aditional error messages.
(EE) Failed to load module "nvidia" (module specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

please consult the X.org foundation support
          at http://wiki.x.org
for help
please also check the log files at "/var/log/X.org.0.log" for aditional informati
on
 ddxSigGiveUp: Closing log
giving up
xinit:  No such file or directory (errno 2): unable to connect to X server
xinit:  No suck process (errno 3): server error
julian@box-o-doom:~$_
share|improve this question
    
Possible Duplicate: askubuntu.com/questions/129709/… –  Mitch Jul 8 '12 at 10:07
    
@Mitch as advised in the answer you linked i tried dmesg will add results to original question –  Jules Jul 8 '12 at 10:48
add comment

2 Answers 2

up vote 0 down vote accepted

As you can see from your startx output there seems to be a problem with your nvidia drivers:

FATAL: Module nvidia not found.
(EE) NVIDIA: Failed to load the NVIDIA kernal module please check your
(EE) NVIDIA:     systems kernal log for aditional error messages.
(EE) Failed to load module "nvidia" (module specific error, 0)
(EE) No drivers available.

(BTW, you can find the complete X log in /var/log/Xorg.0.log.)

First try to (re)install the drivers via

sudo apt-get install --reinstall nvidia-current

If startx still does not get you to the desktop now, I'd recommend editing your xserver configuration, e.g. via

sudo nano /etc/X11/xorg.conf

and commenting out the line for the nvidia driver, i.e. change

Section "Device"
    ...
    Driver      "nvidia"
    ...
EndSection

to

Section "Device"
    ...
    # Driver        "nvidia"
    ...
EndSection

and close nano with Ctrl+x and y to save the changes.

Then run startx again. Maybe this will start your desktop with a lower resolution than usual and you will not have any 3d acceleration, but you should at least get to the desktop again.

If so, uninstall / reinstall your nvidia drivers via the Additional drivers app in system settings and hopefully that'll fix it. You might have to edit xorg.conf again and uncomment the Driver line manually after reinstalling the driver.

share|improve this answer
    
nvidia drives re-install appeared to work, but then told me module build for the currently running kernal was skipped since the kernal source for this kernal does not seem to be installed startx didn't work. i'm about to try editing my xserver –  Jules Jul 8 '12 at 13:46
    
the file etx/X11/xorg.conf seems empty and i'm confused by "commenting out" –  Jules Jul 8 '12 at 13:53
    
worked out that etx was supposed to be etc and i have a GUI again! not sure if everything is working completely but a huge improvement! thank you! –  Jules Jul 8 '12 at 14:01
    
@Jules yes it should have been etc, fixed that in my answer. Congrats on having the desktop back. The message from reinstalling the drivers you quoted above seems to indicate that there are some other packages missing. You should now try installing the drivers via the additional drivers applet in Ubuntu system settings, as I indicated above. Should work. –  nem75 Jul 8 '12 at 14:48
add comment

To change the default from a command-line to GUI, try editing the GRUB configuration.

  1. Edit /etc/default/grub

    sudo nano /etc/default/grub

  2. Find this line:

    GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash text” or

    GRUB_CMDLINE_LINUX_DEFAULT= ”text”

  3. Change it to

    GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

  4. Update the GRUB configuration

    sudo update-grub

share|improve this answer
    
i tried startx will add results to question –  Jules Jul 8 '12 at 11:23
    
just tried sudo gedit /etc/default/grub asks for password then shows me (gedit:1454): Gtk-WARNING **:cannot open display: –  Jules Jul 8 '12 at 11:46
1  
-1 for telling someone who cannot boot to the desktop to use gedit –  nem75 Jul 8 '12 at 13:10
    
@nem75 It was a typo... –  Emerson Hsieh Jul 8 '12 at 14:27
    
@EmersonHsieh IMO nanp -> nano would be a typo, but not recommending a completely different program. Be that as it may your answer does not really have any relation to the question asked anyway, sorry. –  nem75 Jul 8 '12 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.