Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I do a search in the software center this is what the results look like.

enter image description here

I can only see the text if I select one of them.

I tried changing themes but that didn't fix it.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

This might be a problem with your font. If you are using Gnome Shell, install Gnome Tweak Tool, a customization tool for Gnome Shell, with the command sudo apt-get install gnome-tweak-tool, launch it, and change your font from there. If you are using Unity, install Myunity, a Unity customization tool, with the following comands.

sudo add-apt-repository ppa:myunity/ppa

sudo apt-get update

sudo apt-get install myunity

Then, launch Myunity and change your font from it.

share|improve this answer
    
It seems that there are different types of themes for different parts of the GUI. I was assuming there was only one, like in Windows. I fixed the problem by using gnome-tweak-tool to change the GTK+ theme. –  z-buffer Jul 7 '12 at 23:27
    
gnome-tweak-tool was already installed on my system, but gnome-do did not recognize the command and it's not in the Applications menu. How can I add it there? –  z-buffer Jul 7 '12 at 23:29
    
nvm, it's in System Tools->Preferences->Advanced Settings. –  z-buffer Jul 7 '12 at 23:31

I copy the answer here:

I know a number of people have trouble using dark themes with Ubuntu because the software center likes to keep its white background and also use the default light colored text. The following solution is pretty hack-tastic and I'm hoping to hear some more elegant ideas. 1) Open up a terminal and type: Code: gksudo gedit /usr/share/software-center/ui/gtk3/css/softwarecenter.css 2) The first two lines should look like this: Code: @define-color light-aubergine #DED7DB; @define-color super-light-aubergine #F4F1F3; Copy and paste those two lines right below then comment out the originals. Change the two HTML color codes (#DED7DB and #F4F1F3) to your preferred dark colors so that light text will show up. 3) Save and close gedit. Launch Ubuntu Software Center to check out the results

link: http://ubuntuforums.org/showthread.php?t=1913590

share|improve this answer

To summarize, do what tnq177 said and change both RGB values to #333 (they don't need to be #333333).

This is an issue that should have been resolved for ages in Ubuntu Gnome/Gnome Remix. Fine tuning is not the strong point of the Gnome 3 project ....

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.