Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I upgraded from Natty to Oneiric and then immediately to Precise, for some reason the overlay scrollbars stopped appearing. They were enabled and worked just fine in Natty, and are still enabled in theory. I've purged and reinstalled these packages: overlay-scrollbar, liboverlay-scrollbar-0.2-0, and liboverlay-scrollbar3-0.2-0. That did nothing. I also tried using both Ubuntu Tweak and Unsettings, but both showed that overlay scrollbars were turned on (and turning the settings off and back on again did nothing either).

Any ideas how to get them back? Thanks!

Edit: I just read that some people disable them by adding a line in ~/.xprofile or /etc/X11/Xsession.d/99disable-overlay-scrollbars, but those files don't exist.

share|improve this question
    
Please try sudo apt-get --reinstall install ubuntu-desktop –  izx Jul 7 '12 at 19:15
    
Thank you for the suggestion, but that did not work. –  Aibara Iduas Jul 7 '12 at 20:42
add comment

3 Answers

Linuxicle explains how to enable and disable the overlay scrollbar in easy method.

gsettings reset com.canonical.desktop.interface scrollbar-mode 
share|improve this answer
add comment
up vote 0 down vote accepted

I found a file called 80overlayscrollbars in /etc/X11. Despite the filename, it had the line export LIBOVERLAY_SCROLLBAR=0, so it was actually disabling them. Since I never changed the defaults, I really wonder why the upgrade process managed to disable them.

share|improve this answer
add comment

Try installing dconf Editor from the Ubuntu Software Center. It has an option for enabling/disabling overlay scrollbars. The option is located under the following subfolders(click triangles to open) org> gnome> desktop> interface. In the options pane the last item in the list for interface options is ubuntu-overlay-scrollbars which has a checkbox. Click a checkmark in the box, close dconf, log out/in, and it should work.

I often switch appearance themes to high contrast and back which seems to lose the scrollbar setting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.