Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a clean installation of Ubuntu 12 and I installed bashmarks, a utility to have favorites folders on the terminal.

One of the steps is to include source ~/.local/bin/bashmarks.sh at the end of ~/.bashrc, so each time you open a terminal it loads bashmarks.

If I run source manually it starts working, but when I open a terminal is not sourced automatically.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Sounds like a double to this question. It might be that the bash in your terminal is a login shell what means .bashrc is not sourced.

share|improve this answer
    
Thanks! I added source /home/juan/.bashrc at the end of .bash_login and now it works! –  johnblanco Jul 8 '12 at 17:48
add comment

The problem may be that the tilde expansion is not working at the time that .bashrc is being run. It may work if you either put the full directory, or use $HOME instead of the tilde.

Looking at my system-supplied .profile, they run .bashrc, if available, by using this command: "$HOME/.bashrc"

Perhaps you should try a similar statement:

"$HOME/.local/bin/bashmarks.sh"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.