Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This really doesn't make sense. I've been using many other distros and never had such difficulty managing autostart services.

I found three ways of disabling autostart services, and none of them works for me:

update-rc.d -f service_name remove
chkconfig --level 12345 service_name off
sysv-rc-conf

I tried all the three ways to disable mysql daemon, mongo daemon, redis server, cups daemon, yet all of the utilities confirmed that the daemons are disabled, yet they still automatically start on boot.

Please suggest the most correct way to disable services from auto-start at boot. Thank you!

btw, it's running 12.04

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Ubuntu has been moving away from sysv-init to Upstart. Some scripts won't work with: (as they have been moved to the Upstart format)

update-rc.d -f service_name remove
chkconfig --level 12345 service_name off
sysv-rc-conf

This has been answered in other posts, best answer I've seen so far is: (if you want more documentation on it)

http://askubuntu.com/a/19324/23779

So in a brief comment:

The current situation is: Ubuntu now uses Upstart. Some services still use the old sysv-init, are located in /etc/init.d/ while other services, Upstart optimized are in /etc/init/. How to disable, stop, start, etc is explained in the above link.

share|improve this answer
    
that helps a lot, thank you. apparently /etc/init/SERVICE.override file does not have effect, but I'm able to disable mysql/mongodb/redis by using their own .override file. However I'm still unable to find a way to disable ntpd and dnsmasq... any further suggestions please? –  Howard Jul 7 '12 at 22:26
add comment

Bum is good startup manager suggested by many Ubuntu Users . open your terminal and type as

sudo apt-get install bum

and to Launch the Bum , type this in your terminal .

gksu bum

Hope that helps .

share|improve this answer
    
thanks, I'm sure it'll help once I have a window manager installed C: –  Howard Jul 7 '12 at 22:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.