Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen a detailed tutorial on installing u-torrent but after i enter, last line of code, it says:

'bash: /usr/bin/utserver: No such file or directory'

syntax; utserver -settingspath /opt/utorrent-server-v3_0/
share|improve this question
    
I think it is best to use transmission if you intended to download only. However here - askubuntu.com/q/104094/35775 is a brief tutorial. I think you missed the step while creating hard link sudo ln -s /opt/utorrent-server-v3_0/utserver /usr/bin/utserver –  Web-E Jul 7 '12 at 12:43
    
give us the Tutorial link and terminal code in paste bin . Thank you . –  raaz Jul 7 '12 at 12:43
    
Web-E; Thank you for your response.I tried those steps again and at the line which you said that i missed it..It said 'ln: failed to create symbolic link `/usr/bin/utserver': File exists'. And after entering the final syntax it ended up showing the same error which i posted above. Hope you understood what i said,thank you –  srujan Jul 7 '12 at 12:58
    
His problem is he downloaded the 32-bit version but doesn't have ia32-libs (see answer) –  izx Jul 7 '12 at 15:43
    
Please consider accepting/upvoting my answer to this question, if you feel it solved your problem or helped you out (tick/check mark on the left). This way, the question is marked as \"answered\" and future readers can refer to it knowing the solution works. Thank you...:) –  izx Jul 26 '12 at 11:44
add comment

1 Answer

You must install 32-bit compatibility libraries or use the native 64-bit uTorrent Server

  • You are using 64-bit Ubuntu
  • You downloaded the 32-bit version of utserver, which requires the ia32-libs compatibility package on 64-bit Ubuntu (or you get the cryptic file not found error)
    • You can fix this problem with sudo apt-get install ia32-libs
  • Better yet, get the native 64-bit version of uTorrent Server:
    • wget http://download.utorrent.com/linux/utorrent-server-3.0-ubuntu-10.10-27079.x64.tar.gz
    • After that you will need to install libssl v0.9.8 to get it work, with sudo apt-get install libssl0.9.8

Educational screenshot, or "how did you know that?":

enter image description here

share|improve this answer
    
+1 for finding out the arch type of OP :) –  tijybba Jul 7 '12 at 16:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.