Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed new ASRock B75M-ITX Mainboard and fresh Ubuntu 12.04 on it.

During the boot, there is a 20 to 40 seconds pause when goa-daemon is starting (/var/log/syslog):

Jul  7 11:13:28 sirius goa[1933]: goa-daemon version 3.4.0 starting [main.c:112, main()]
Jul  7 11:13:51 sirius kernel: [  102.771893] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

Any ideas what is wrong and how should I proceed trouble-shooting this?

EDIT: Thank you for the tip regarding ATA. I've found following in the logs:

Jul  8 10:54:20 sirius kernel: [    6.007532] ata1: link is slow to respond, please be patient (ready=0)
Jul  8 10:54:20 sirius kernel: [   10.648618] ata1: COMRESET failed (errno=-16)

The problem vanished when I've reconnected the Intel G1 SSD from SATA3 to SATA2 connector.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The source is most probably not goa-daemon but a delay/error in accessing your hard drive:

ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

ata/frozen typically appears after a drive fails to respond and the kernel has tried/re-tried the operation a few times, which may explain the 20-40 second wait.

To troubleshoot further, please pastebin the content or output of the following commands/files (instructions in this answer): file(s): /var/log/kern.log, /var/log/syslog and command(s): dmesg.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.