Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday my Ubuntu 12.04 (Wubi) system was working completely fine. But today when I tried to boot I was brought to a GNU GRUB screen. Typing boot yields no kernel specified or something along those lines.

After going through many forums and Q/A sites and typing many lines of code into the grub> terminal, I have gotten nowhere. Most of what I type returns something about the kernel not being found and an I have no way of finding out my kernel version.

I am dual-booting alongside Vista and have also tried replacing wubildr. My root.dsk is also present so that is not an issue as many websites state.

Any help would be good and if more information is needed I will try and find it out.

share|improve this question
    
Try Boot-Repair –  Mitch Jul 7 '12 at 14:19

1 Answer 1

Did you update your kernel? If so you might have a problem because the grub.cfg generated by wubi is different from the one generated by update-grub after you update.

In the original grub.cfg generated by wubi, the root.disk will be mounted through the loopback device and used as the root, and then the location of the kernel is specified according to this root directory.

After you update your kernel, the grub.cfg file won't do the same because update-grub won't know that you are using wubi and needs to mount root.disk.

The solution to this is to take a look at the grub.cfg file before your update (if you still have it or find it somewhere else) and update the grub.cfg manually using a liveCD.

Wubi is just for experiencing ubuntu on windows, but not for long-term usage.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.