Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I executed this command in a terminal by going to the folder where I placed the installation file.

santiago@CHAPA:~/Descargas/Matlab/MATLAB$ sudo sh install

but this showed in the terminal

Preparing installation files ...
Installing ...
install: 1: eval: /tmp/mathworks_6992/sys/java/jre/glnx86/jre/bin/java: Permission denied

Can anyone help me?

share|improve this question
    
I have this problem too. Did you resolve it? –  Primož Kralj Sep 6 '12 at 11:49

3 Answers 3

up vote -1 down vote accepted

from the installation directory do this

$ cd java/jre/glnx86/jre/bin 
$ chmod +x java

basically you have to convert the files in ~/Descargas/Matlab/MATLAB/java/jre/glnx86/jre/bin directory into executables.

after this continue with the normal installation from installation directory

$ sudo sh install
share|improve this answer
    
thanks... but with the firs line i get this bash: cd: java/jre/glnx86/jre/bin: No existe el archivo o el directorio –  Santiago Paladines Jul 7 '12 at 23:12
    
Actually it should be cd sys/java/jre/glnxa64/jre/bin and then chmod.. But it still doesn't work. –  Primož Kralj Sep 6 '12 at 11:53
    
i going to try it thanks –  Santiago Paladines Oct 11 '12 at 15:45

The answers here and in this post: How do I install MATLAB R2012a? did not help unfortunately.

For me this procedure worked -- Install instructions:

1) copy DVD content into a folder in home - e.g. MatInstall

2) change directory to folder with iso content:

cd MatInstall

3) make install and java executable:

chmod u+x install
chmod u+x sys/java/jre/glnxa64/jre/bin/java

4) create MatLabTemp directory in home:

mkdir $HOME/MatLabTemp

5) open a terminal and type the installation command:

$HOME/MatInstall/install -javadir $HOME/MatInstall/sys/java/jre/glnxa64/jre/ -root $HOME/MatInstall/ -tmpdir $HOME/MatLabTemp

( with this command we tell the Matlab Installer manually where to look for the data, temp directory and java)

share|improve this answer
1  
Thank you, that actually helped. I would recomment using sudo on the last command, since it will need to create a default folder in /usr/local –  sdkfasldf Dec 26 '13 at 0:59

I think you should go to root mode first by executing the following command: $ sudo -s

Then, you can execute: $ ./install

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.