Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Xubuntu 12.04 with Network Manager on my HP 5310m Laptop and get a weird problem on wired network.

When googling for answers, I found many people get the problem that wireless disconnects when laptop unplugged. For example, this question: Wireless disconnects when laptop unplugged from power source

However, my problem is that my wired network of my laptop will auto disconnect when unplugged from a power source. Now if I want to use wired network, I must have my laptop plugged. If someone unplugged the power source of my laptop, my network connection will lost at the same time.

I think this may be some kind of "power-save" method but I searched /etc/pm-utils/power.d/ without find anything about wired network.

Can anyone help?

share|improve this question
    
Take a look at this: askubuntu.com/questions/98936/… –  Mitch Jul 7 '12 at 6:28
1  
@Mitch Sorry, but I am not using a PPPoE connection. It's a Ethernet connection. And the problem occurs when I unplug the power source, not when powering up the laptop for some while... –  wzyboy Jul 7 '12 at 11:03

2 Answers 2

Well, I almost forgot that I asked here this question.

I have already figured out why. There is nothing to do with software, drivers, et cetra. This is indeed a hardware issue. The motherboard of my laptop will automatically turn off the wired NIC when unplugged. There is a switch in the CMOS setting named "Power save on LAN". Turning if off solves this issue.

share|improve this answer

Wired or wireless works on the same way in NetworkManager daemon.
To avoid using it I had set up my own static eth connection for networking service in

/etc/network/interfaces<br/>

iface eth0 inet static<br/>
address 192.168.1.2<br/>
netmask 255.255.255.0<br/>
gateway 192.168.1.1<br/>

Then remove eth dhcp from the NetworkManager gui, otherwise it overrides it.

You can also set up dhcp there:
auto eth0
iface eth0 inet dhcp

If your eth is not eth0, you need to change here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.