Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have downloaded the shell script (Workbench_2.0.0_LINUX.sh), I have run it as root with it giving no complaints, relevant looking files have appeared in /usr/local/Wolfram/WolframWorkbench/2.0/ and it has created the executable "WolframWorkbench" in /usr/local/bin.

However, when I run WolframWorkbench from terminal it spits out

/usr/local/bin/WolframWorkbench: 46: exec: /usr/local/Wolfram/WolframWorkbench/2.0/WolframWorkbench: not found

That file does indeed exist, and is executable. I have also tried running it directly, and I have also tried running the /usr/local/Wolfram/WolframWorkbench/2.0/Executables/WolframWorkbench too. Is there something I'm missing?

(I am running Ubuntu 12.04 64bit with openjdk7)

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It's a 32-bit executable which requires the ia32-libs compatibility package on 64-bit Ubuntu. Fix your problem with the below and then try running it again:

sudo apt-get install ia32-libs
share|improve this answer
    
that was the problem! I should have posted earlier, I wasted too much time trying to figure this out. –  Ian Hincks Jul 7 '12 at 0:23
    
Unfortunately, unless you already know about it, only using strace to execute will tell you why the file is "not found" :) –  izx Jul 7 '12 at 0:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.