Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running i386 (32-bit) natty, and have installed crash, but it doesn't work on the running system. I found the solution on the crash author's page -- the problem was fixed in 5.1.6 and I have 5.0.7 -- but I can't find a way to upgrade crash to 5.1.6 using either synaptic or apt-get.

The machine in question does not have Internet access, so I've downloaded crash_5.1.6-1ubuntu1_i386.deb onto a flash drive (using a different machine) and mounted it on the machine where I need the upgrade. However, when I try to install it, apt-get claims that it can't find the package. (I've tried many variations on this, and also tried using synaptic; and yes, I'm aware that the "-s" will keep it from actually doing anything -- I want to be sure of what-all it will do before letting it do it -- but shouldn't it still find the file?)

$ uname -a
Linux tester-2012-Client-Platform 3.2.12 #3 SMP Fri Jul 6 14:34:59 PDT 2012 i686 i686 i386 GNU/Linux
$ (cd /media/16FB-E6BB/pkg && ll crash_5.1.6* && sudo apt-get -s -V --no-download -u install crash=5.1.6 )
-r--r--r-- 1 tester tester 2277846 2011-06-17 01:05 crash_5.1.6-1ubuntu1_i386.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '5.1.6' for 'crash' was not found

As shown by the "ll" output, the file does exist. How do I get apt-get to see it?

share|improve this question

closed as too localized by izx, hbdgaf, belacqua, Jorge Castro, ajmitch Aug 22 '12 at 3:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You cannot use that deb because it's for 11.10/Oneiric, not for Natty. The highest version officially released for Natty is the buggy 5.0.7 you have. Sorry, but you'll have to build from source, or find a PPA. –  izx Aug 8 '12 at 7:32
    
Or you remove the old crash, search all the dependencies and their dependencies in the package search for precise, download them for precise, install them and after a long and tedious session of manual .deb installation you'll really appreciate aptitude. –  con-f-use Aug 19 '12 at 11:51

1 Answer 1

up vote 0 down vote accepted

Have you tried to just double click the .deb file? That should install it using Ubuntu Software Center.

share|improve this answer
    
It had not occurred to me to try that previously. (I'm quite new to Ubuntu.) It looks as if it may have worked, at least there's no error message. –  Perry Hutchison Jul 10 '12 at 0:11
    
That seems to have worked, and the original problem (not recognizing the kernel image as matching the running system) is fixed, but now "crash" reports a "read error" when asked to display the contents of a kernel virtual address that is known to be valid. Any idea (or is there a different way to examine kernel memory)? –  Perry Hutchison Jul 10 '12 at 17:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.