Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using VirtualBox 4.1.12, as packaged in Ubuntu 12.04, I'm unable to use USB 1.1 device (a Canon FS-4000US scanner) within a Win XP VM. I'm able to connect other USB devices, such as a USB flash drive, fine, yet the scanner gives:

Failed to attach the USB device Canon Scanner [1001] to the virtual machine WinXP.

Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

As follows from other devices working, I'm in the vboxusers group. Any ideas?

share|improve this question
2  
Note: please pastebin the output of lsmod. 0x80004005 in most contexts is a permissions error or file not found error (that presents as permissions). that error code is a blanket for "i tried to read something but couldn't". if you want to see what i mean back up your vbox xml and change a disk-id to something that doesn't exist or change the permissions on a disk to root only. –  izx Jul 7 '12 at 0:08
    
@izx pastebin.com/KaPGTZBa (will incorporate into question if any of it turns out to be relevant; don't see anything there myself) –  gsnedders Jul 7 '12 at 0:43

1 Answer 1

Some things that helped me:

  • Disable USB3 ("XHCI") temporarily in BIOS/UEFI system settings. Some instructions hint on using different USB port (eg. one with only USB2 support), but that did not help me.
  • Edit/add temporarily /etc/modprobe.d/blacklist-local.conf and add lines "blacklist usb_storage" and "blacklist keucr" to it. Reboot, but note you'll lose access to any USB storage like it says.

After that I was able to mount a SD card reader in VirtualBox, even without USB filter as such but just selecting it from the USB menu during runtime.

Ubuntu 12.04.4 LTS (3.11 kernel), Asus Z87 motherboard, latest VirtualBox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.