Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to precise my audio is stuttering. It is happening, in VLC, mplayer, and anything streaming from the internet. I followed the procedures in https://help.ubuntu.com/community/SoundTroubleshootingProcedure but nothing has helped so far. There is the problem that the driver version is out of date but it does not seem to want to update with the given commands.

$ bash alsa-info.sh --stdout |grep version
Driver version:     1.0.24
Library version:    1.0.25
Utilities version:  1.0.25

How can I upgrade the driver and fix the stuttering?

share|improve this question
add comment

5 Answers 5

Once it stutters I always got rid of this problem by killing/restarting pulseaudio.

  1. sudo killall pulseaudio
  2. sudo pulseaudio --system=1 --daemonize
  3. Close and re-open chromium
share|improve this answer
    
This worked like a charm for Firefox also. –  Clutch Oct 17 '12 at 21:08
add comment

I followed the answer/tutorial in How to solve jitter (or stutter) playback via Chrome flash plugin? and now playback seems to work again:

  1. Go to chrome://plugins in Chrome.

  2. Activate the details by clicking on the "+"-sign which you find on the top, right side.

  3. Deactivate the Chrome flash plugin: On my system it is located in /opt/google/chrome/PepperFlash/libpepflashplayer.so.

  4. Use the one which is installed together with Mozilla Firefox: On my system it is located in /usr/lib/flashplugin-installer/libflashplayer.so

Unfortunately I would not entitle this as a solution for your problem. It is more a workaround until the problems with the original Chrome flash plugin are solved. But until then you are still able to use your Chrome browser.

share|improve this answer
add comment
up vote 0 down vote accepted

I found that it is specific to Google Chrome. Unfortunately whenever Chrome is running it also interferes with audio in other places as well, but since chrome is almost always running it was difficult to track down. Solution: switched back to firefox, as audio problems are too large to ignore. Audio problems are gone now. I'll check with chrome again after a few updates.

share|improve this answer
add comment

For VLC - in the menu go to preferences. Choose Audio settings, and change the audio output module to Alsa audio ouput. Close and restart VLC.

share|improve this answer
add comment

12.04 - Ubuntu/Linux Audio Skipping/Stuttering

I fixed this problem system wide, by changing the audio standard in my BIOS from HD to AC97. Ever since then, I've had zero problems with audio in my computer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.