Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently set up ubuntu 12.04 on my laptop using the Wubi installer. I am having a very difficult time setting up a wireless internet connection. I am currently set up with an ethernet connection which I have used to download all new updates and to activate the Broadcom STA wireless driver.

I have tried several things in the terminal based on other people's posts:

~$ rfkill list
0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: yes

~$ rfkill unblock all

It doesn't change anything. I also tried rebooting and connecting to the internet on my Windows Vista OS, and it worked, so I know that the connection should not be hard blocked. I have also tried installing b43 firmware (lp/phy version) that is supposed to work with my chip (BCM4312). It seems to have no effect.

Then I tried:
~$ iwconfig
lo no wireless extensions.

eth1 IEEE 802.11 Access Point: Not-Associated
Link Quality:5 Signal level:0 Noise level:0
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

eth0 no wireless extensions.

This is my first time trying to work with ubuntu, so I would appreciate any help. Thanks.

Also sorry this is poorly formatted. I'm having troubles with that too.

share|improve this question
add comment

1 Answer

http://ubuntuforums.org/showthread.php?t=1596061

share|improve this answer
2  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Jul 6 '12 at 20:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.