Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to stop ubuntuone from autostart.

I have already tried the suggestions from this answer but it didn't help me. My current status is that I have deleted the ubuntuone-launch.desktop file from /etc/xdg/autostart but the service still start's at log-in.

Any suggestions before purging it?

share|improve this question
add comment

6 Answers 6

up vote 3 down vote accepted

Install Boot Up Manager

sudo apt-get install bum

and disable the service from Boot Up Manager.

share|improve this answer
    
If this answer solved your problem please click on the grey tick mark to mark it solved. –  Schweinsteiger Aug 16 '12 at 19:30
    
I have only checked the outcome today. After bum, I did not see Ubuntu-One there (I did stop some other services though, from boinc) now I don't have Ubuntu one started. So I am not sure what happened...but U1 is no longer auto-started, and that's what I was aiming at. Thx all! –  bioShark Aug 18 '12 at 14:38
add comment

Ubuntu One starts automatically while there is a folder called "Ubuntu One" in your $HOME, thus delete that folder if you want to prevent Ubuntu One from autostart.

Then if you want, you can also restore the factory settings by deleting the following hidden folders from your $HOME

.local/share/ubuntuone/
.config/ubuntuone/

Please note that you don't have to delete /etc/xdg/autostart/ubuntuone-launch.desktop file, in fact if you do so you might be into trouble when you want to use Ubuntu One again, however you can rebuilt it with:

sudo gedit /etc/xdg/autostart/ubuntuone-launch.desktop

by pasting the following and saving changes:

[Desktop Entry]
Name=Ubuntu One
Exec=/bin/sh -c '[ -d "$HOME/Ubuntu One" ] && ubuntuone-launch'
Type=Application
X-GNOME-Autostart-Delay=30
Icon=ubuntuone
Comment= 
NoDisplay=true
X-Ubuntu-Gettext-Domain=ubuntuone-client
share|improve this answer
add comment

Maybe you include a simple script in your custom start up applications:

#!/bin/sh
u1sdtool -q

And the daemon should quit as soon as you log in.

share|improve this answer
    
I know about this solution :) I have quite a few scripts already starting up on log-in. I was looking for an "official" stop autostart. –  bioShark Jul 6 '12 at 20:03
add comment

Try to open the Ubuntu One dashboard, go under "Settings" tab and uncheck the "Connect automatically when computer starts". This way you can simply enable it after boot manually.

Hope it helps

share|improve this answer
3  
that one is already disabled, and it's the same issue. I think this option only refers to the synchronisation, not to the start-up of the daemon. –  bioShark Aug 16 '12 at 19:23
    
You're posing a good question :) after this bug fix it should not start. In fact it is not a service (bum or something else will not even see it - it is not a script in /etc/init.d but is a daemon in /usr/lib/ubuntuone-syncdaemon). Maybe you can see if it starts looking for it in 'ps aux | grep ubuntuone-*'. If so, you can update that bug and try to remove daemon from that folder in the meanwhile (but be careful, don't know how system will complain about this :)) –  Omegafil Aug 18 '12 at 9:42
1  
I have only checked the outcome today. After installing Schweinsteiger's recommendation (bum), and indeed not seeing Ubuntu-One there (I did stop some other services though, from boinc) now I don't have Ubuntu one started. So I am not sure what happened...but U1 is no longer auto-started, and that's what I was aiming at. Thx all! –  bioShark Aug 18 '12 at 14:37
add comment

I simply uninstalled UbuntuOne... Easy peasey.

share|improve this answer
    
:) I am waiting for a solution first. –  bioShark Jul 6 '12 at 19:45
add comment

Type in terminal

cd /etc/xdg/autostart/
sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Reboot , select the Startup applications from the Top right Corner Menu, there in list you will see Ubuntu One as option , Just Un-Check it to disable it Auto-restarting from next time.

share|improve this answer
    
As I have written in the question I no longer have the ubuntuone-launch.desktop file in /etc/xdg/autostart/ folder. Furthermore there is no Ubuntu One in the Startup application. The problem is that the service is being started at startup –  bioShark Jul 6 '12 at 20:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.