Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been reading article after article and asking around in the chats for help on why this is not working :(

Here is what I've done so far:
I have installed samba following the server guide in the first link posted.
I have edited my smb.conf file.. here is (what I think) is the relevant part of that for you to see..

[homes]
   comment = Home Directories
   browsable = no
   writable  = yes
   valid users = %S
   valid users = MYDOMAIN\%S
   create mask = 0755
   directory mask = 0755

I have created a user running sudo adduser wks. This successfully adds the user and creates the home folder with group and user permissions set to "wks". Now I add that same user to samba smbpasswd -a wks no errors all seems to go well.

Ok so from here I should be at the very least be able to goto a windows machine, open up the network computers, find the server, and open the home folder for "wks"??
At the moment I can do all of these things but access the home folder (even with the username and password I set in the previous steps).

Have I missed something trivial? Was that a bad tutorial to read from? I am confused how to proceed from here.

TO summarize: the user wks (this happens to also be the windows credentials.) with the supplied password still does not have permission to access the home folder while accessing it with windows.

edit

I double checked on windows to make sure I was seeing it in the workgroup... I am not. Is there a step I missed? in smb.conf I have workgroup = DMSI and the windows computers are all part of that workgroup.

share|improve this question

1 Answer 1

Check out these Samba Troubleshooting links:

Also, check the manual with this console command:

  • man smb.conf

The "valid users" option accepts user names or group names. I don't think it can be listed twice, and it may not be able to interpret the %S value.

Edit: trying to enable security while creating a new setup will always complicate the troubleshooting process. For example, is the problem with the initial setup, or that your security is blocking the user? So remove the "valid users" until you get the connection working. Later, you can add security back into the process, and you will know that the "valid users" syntax is the only portion you'll need to troubleshoot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.