Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've Xubuntu 12.04 installed on my HP DV-4 laptop, and it was working fine with my previous wifi router - a Buffalo Air Station WHR-HP-G54.

I recently replaced the Air Station with a new Netgear WNDR-3800... basically gigabit ethernet ports, added multi-band 802.11n, etc.

Everything in the house has been reconnected to the new network - iPods, iPhone, Kindle Fire, Macbooks, even this HP DV-4 laptop - when it boots in Windows Vista 64.

When in Xubuntu 12.04, Network manager 'sees' the network(s), just as before... but cannot connect to them. It just sits there with the icon 'spinning' until it times out.

Regular 'wired' connection works fine... just can't seem to connect to the wifi network(s) - any of them.

Shouldn't be anything 'special' required; none of the other devices needed anything other than the new password to connect.

Ideas?

share|improve this question
add comment

1 Answer

According to HP, your laptop supports Intel 802.11b/g/n.

Try this, download wicd and see if it connects. I had the same problem earlier on a cheap Lenovo ion laptop, although it now works with network manager in 12.04. Recently, the chip used for WiFi had problems with Linux, but Ive not heard of this lately. Update your question with wicd results.... Good luck

This sometimes happens with wicd.

Check this out, too.

Good luck...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.