Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on a Lenovo Z570 laptop with Intel HD 3000 integrated graphics, and a switch to enable the dedicated GT630M graphics card. I've been having issues in general with my graphics drivers and whatnot.

Ubuntu's system settings say that it can't detect any graphics driver (it lists 'Unknown'), although the quality graphics including fade effects, Unity 3D, etc. tell me that one of the cards must be functioning just fine. My decent unplugged battery life suggests that the dedicated graphics is disabled (plus I Googled a solution that allowed me to force the external card off on boot, sorry but I can't remember what I did or where I found it). In Windows, I can hit a switch to toggle the dedicated graphics on and off, along with an indicator light, but that feature doesn't work in Ubuntu and the light remains on no matter what.

Secondly, I'd like to get the proper drivers installed for maximum performance (if they matter). In an earlier installation of 12.04, I tried to install the NVIDIA driver and ended up screwing up my resolution so bad that I just had to reinstall Ubuntu. I'm not even sure if the Intel integrated graphics need a driver to function properly.

Sorry if I'm being a bit confusing; this is more of a general issue than a precise question, but if I could get some answers to these questions it would be great:

1) Is there any way I can detect for certain whether or not the dedicated GT630M is being used?

2) Is there any way I can enable the ability to switch between the cards?

3) Which driver(s) should I install, and how can I go about doing that? When I tried to install the NVIDIA driver, I ended up going through a whole bunch of command-line stuff that I really didn't understand just to get the installation to work, then I just smashed enter at all of the installation prompts because I hardly understood any of them.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

I have the exact same Nvidia Geforce GT 630M in my laptop. The solution is basically run these commands:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

Then when you need 3D graphics for a program, run it as optirun program. To save power on laptops, it runs only that single program through your nvidia graphics card. To start nvidia-settings, run this optirun nvidia-settings -c :8

Unfortunately, Nvidia doesn't officially support these hybrid cards on Linux. For more information on bumblebee project, follow this link http://bumblebee-project.org/

If you have errors like any of these:

[ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ERROR]Aborting because fallback start is disabled.

The "Failed to initialize NVIDIA GPU" error appears in syslog from bumblebeed / Xorg.8

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device
[10de:0fd1] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: nvidia

Then you may be experiencing this GT 650M bumblebee bug. Please send in any information you can to help resolve this. Other problems can be reported here: https://github.com/Bumblebee-Project/Bumblebee/issues

share|improve this answer
    
Thanks! I actually found Bumblebee after some further research and installed it. Getting some better battery life already, although it is a shame that I still can't utilize the physical switch on the front of my laptop. However, the system still doesn't recognize my Intel graphics (it still lists 'Unknown' in the system settings). Is this going to affect battery life or performance? –  Alex Jul 6 '12 at 15:32
1  
When I run glxgears by itself, it runs at about 50-60fps. You should experience similar results if your Intel Graphics Card is working properly. If you get a very low number like 10fps or less, than your Intel Graphics Card is Not being utilized as it should be. In that case, installing mesa-utils may fix the problem. (If it doesn't fix the problem, post a new question) –  Sepero Jul 6 '12 at 15:53
    
When I run glxgears I get about 60FPS, when I type 'optirun glxgears' then I get 300-400FPS. So I guess that means it's working properly. Thanks! –  Alex Jul 8 '12 at 2:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.