Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading to 12.04 (64-bit), i've noticed an issue while watching DVDs in VLC - the sound will "glitch" - that is, it'll replay a tiny sample over and over for about a second or so, and then continue playing.

It's the same effect as if you're listening to something and your machine locks up hard, and it plays the same sound ad nauseum until you cut power. However, in my case, it clears after approximately a second.

During this time, the video continues to play uninterrupted. The sound resumes in time with the video (everything that would have been played during that second is lost - it doesn't replay it quickly or get behind).

Advice on debug steps would be greatly appreciated.

share|improve this question
    
I see it outside of just VLC too - watching flash videos does it as well. –  Matt Sachtler Jul 7 '12 at 1:28

2 Answers 2

I had the same issue with my mp4 files I did this, and its seems to have fixed it for me...

sudo mv /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak

Taken from here: http://www.webupd8.org/2012/06/fix-mp4-playback-in-ubuntu-1204.html

Dont know if it will help you, but it fixed mp4's for me.

share|improve this answer
    
However, vlc does not use gstreamer to play mp4 streams; and DVDs are encoded in mpeg2, so that this solution will not work for Matt. –  user76204 Jul 19 '12 at 10:01

I've got the same problem as Matt and have improved the issue greatly (not solved) with updating ALSA from running through the following steps: https://help.ubuntu.com/community/SoundTroubleshootingProcedure

In addition, I'm only having this issue on a system that is using a Realtek ALC887-VD card together with ATI 5450 card (HDMI). Are you running this hardware as well?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.