Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run vlc from terminal I get:

In the VLC dialog box:

Your input can't be opened:
VLC is unable to open the MRL 'file:///media/Ent/movies/the%20mask.avi'. Check the log for details.

In terminal:

VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
[0x8fe8f8] main input error: open of `file/xspf-open:///home/para/.local/share/vlc/ml.xspf' failed
[0x8fe8f8] main input error: Your input can't be opened
[0x8fe8f8] main input error: VLC is unable to open the MRL 'file/xspf-open:///home/para/.local/share/vlc/ml.xspf'. Check the log for details.
[0x8f1aa8] main interface error: no suitable interface module
[0x8f9b08] main interface error: no suitable interface module
[0x8be008] main libvlc error: option http-user-agent does not exist
[0x8be008] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x8f9b08] qt4 interface error: Unable to load extensions module
[0x7f5280000b78] main input error: open of `file:///media/Ent/movies/the%20mask.avi' failed
[0x8fc718] main playlist error: could not export playlist

This happens for every file i run with vlc. Need help in troubleshooting the problem in vlc , this started when i installed vlc 1.0* by mistake when 2.0.1 was already there so i removed vlc from synaptic package manager and reinstalled it

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I think you need to do several things here; this is what I did when I had a similar problem (see the three commands below). I removed vlc and all its configuration files by running the first command; with the second I removed all the extra items it installs, and with the third I cleaned the apt cache so the package needs to be downloaded again; i.e. /var/cache/apt/archives is cleared.

sudo apt-get purge vlc
sudo apt-get autoremove
sudo apt-get clean 

As has been suggested, it is also important to remove any traces of the program from your home folder, as the purge procedure does not remove them, so remove the following folders as well (use -i instead of -f if you want to confirm removal). It is alright to remove the vlc folders here and not just the contents of the folder, as the folders will be reconstituted when you reinstall vlc.

rm -rf ~/.cache/vlc
rm -rf ~/.config/vlc
rm -rf ~/.local/share/vlc 

That should help eliminate the problems you encountered with the configuration of vlc; it is particularly important to remove the vlc folder in .config as that contains the file vlc-qt-interface.conf, which you mentioned appeared in the error logs and seems to be preventing vlc from opening.

Now you should be able to run

sudo apt-get update  
sudo apt-get install vlc

This should sort out the problem, but we can look into other possibilities if necessary and if you provide further information.

share|improve this answer

Run this to clean your vlc settings, then try running vlc again

rm -rf ~/.local/share/vlc/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.