Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed MAAS and Openstack as guided by https://wiki.ubuntu.com/ServerTeam/MAAS/ and https://help.ubuntu.com/community/UbuntuCloudInfrastructure, however on step 5 it states:

if you are using this to deploy OpenStack on a IaaS for testing purposes, the last step is to expose the services that should be made available to outside requests, opening the required firewall ports in the security group. This is obviously not needed when deploying using MAAS.

Quite frankly it's not obvious how this is intended to work - I don't know how to access the Openstack dashboard. I ran these commands: juju expose openstack-dashboard and juju expose nova-cloud-controller per the guide, however juju status openstack-dashboard still does not yield an address for me to go to. I've tried hitting the ip's of my (hardware) nodes to see if it's living out there somewhere, but got nowhere.

share|improve this question
    
I got it - I just didn't have enough nodes to start up the dashboard yet, it started up on the 9th node... –  Fuginator Jul 6 '12 at 4:57
    
I guess that was only half the issue though - using the second link above, I set the admin password in a file, however it does not work on the web UI (can't log in). Thoughts? Perhaps how to reset it? –  Fuginator Jul 6 '12 at 5:37
    
You may want to edit your question to incorporate information about how your situation has changed. (Click the edit link.) –  Eliah Kagan Jul 6 '12 at 16:04
add comment

1 Answer

When Juju gives you the public-adress: 367pb.cluster01.yourdomain.com style address, you have at add /horizon onto the end of that to get to the web interface page.

All authentication is handled by keystone. You need to ensure there is a relation between the openstack-dashboard and keystone services. You should be able to access the dashboard (initially) using username 'admin' and the password that was set for the 'admin-password' in the keystone section of the configuration you passed to 'juju deploy'. If you forgot to specify the configuration when deploying keystone, one was randomly generated for you by the charm. You should be able to find this in /var/lib/keystone/keystone.passwd on the keystone node.

Hope that helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.