Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have freshly installed 64 bit Win 7 and 12.04 Ubuntu dual boot machine (via a wubi install). I verified that Wubi installed 64-bit Ubuntu 12.04 and I specifically downloaded and installed the 64-Bit virtualbox package from this page on the VirtualBox website.

Ubuntu 12.04 LTS ("Precise Pangolin") i386 | AMD64

(NOTE: I have a TOSHIBA c655, with an Intel Pentium chip inside, there I selected the AMD64 as instructed to on the top of the page)

When I run Virtualbox, it will only allow me to install and run 32 Bit guests (32 bit Win 7, to be specific).

I'm utterly frustrated at this point. I click on "AMD 64", but apparently it is only installing 32-bit. Any help would be greatly appreciated.

share|improve this question
1  
See this question for settings needed: askubuntu.com/questions/41550/… –  Takkat Jul 6 '12 at 6:44
    
This is most likely a BIOS issue. See link above or: VirtualBox FAQ forums.virtualbox.org/viewtopic.php?t=8669 –  david6 Jul 6 '12 at 7:43
    
if you read vbox's page, it says that unlike vmware, 64 bit processors doesn't automaticly mean you can run 64bit quests. –  Dr_Bunsen Oct 28 '12 at 19:20
add comment

2 Answers

64-bit mode requires certain hardware virtualization features in your CPU. As one of the comments states, you may be able to enable these in the BIOS (they are sometimes disabled by default for security reasons).

Some CPU units do not have the required features, or the motherboard they are installed on refuses to enable them.

Unless you have a need to allocate more than 4GB of RAM to a single process in your guest VM, 64-bit offers little advantage over the 32-bit version.

Do cat /proc/cpuinfo | egrep '(vmx|svm)' on your host system ; you will need at least one of these flags to support 64-bit mode guests.

share|improve this answer
add comment

Have you tried installing Virtual Box via the Ubuntu Software Center? It should automatically select the right build (32/64) for your system.

(it's virtualbox with no spaces if you type it in the search field)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.