Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

virt-install says name is in use, but virsh list --all says there is nothing.

jrwren@delays:{%22}~ $ virt-install -d -n android -r 512 --disk android.qcow2 -s 4 -c /d/cd\ images/android-x86-2.2-generic.iso --vnc --noautoconsole 
[Thu, 05 Jul 2012 16:57:19 virt-install 23170] DEBUG (cli:220) Launched with command line:
/usr/bin/virt-install -d -n android -r 512 --disk android.qcow2 -s 4 -c /d/cd images/android-x86-2.2-generic.iso --vnc --noautoconsole
[Thu, 05 Jul 2012 16:57:19 virt-install 23170] DEBUG (cli:326) Requesting libvirt URI default
[Thu, 05 Jul 2012 16:57:19 virt-install 23170] DEBUG (cli:328) Received libvirt URI qemu:///session
[Thu, 05 Jul 2012 16:57:20 virt-install 23170] DEBUG (virt-install:259) Requesting virt method 'default', hv type 'default'.
[Thu, 05 Jul 2012 16:57:20 virt-install 23170] DEBUG (virt-install:469) Received virt method 'hvm'
[Thu, 05 Jul 2012 16:57:20 virt-install 23170] DEBUG (virt-install:470) Hypervisor name is 'kvm'
[Thu, 05 Jul 2012 16:57:20 virt-install 23170] DEBUG (cli:950) --graphics compat generated: vnc
[Thu, 05 Jul 2012 16:57:20 virt-install 23170] ERROR (cli:597) Guest name 'android' is already in use.
(venv)jrwren@delays:{%22}~ $ sudo virsh -c qemu:///system list --all
 Id Name                 State
----------------------------------

Where is virt-install finding this name?

edit: I should mention that LIBVIRT_DEFAULT_URI is not set.

share|improve this question

2 Answers 2

up vote 7 down vote accepted

You are using different URI's in each command. Either add -c qemu:///system to your virt-install command, or change it in your listing to use qemu:///session. To undefine use the command virsh -c qemu:///THECORRECTURI undefine android.

share|improve this answer
    
thank you. i was confused about session v. system. Now I'm rolling with LIBVIRT_DEFAULT_URI=qemu:///system –  Jay _silly_evarlast_ Wren Jul 5 '12 at 21:42

You have to undefined the Virtual Machine. If its running stop it

[root@fed18 isos]# virt-install --hvm --name OracleLinux64-1 --ram 2048 --vcpus 1 -f /dev/virtual-machines/OracleLinux64-1 --network bridge=br0 --cdrom /isos/Oracle_Linux_Release_6_Update_4_x86_64.iso --graphics vnc,listen=0.0.0.0,port=5901 --noautoconsole 
warning: failed to set locale, defaulting to C
ERROR    Guest name 'OracleLinux64-1' is already in use.

root@fed18 ~]# virsh
setlocale: No such file or directory
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
   'quit' to quit
virsh #  undefine OracleLinux64-1
Domain OracleLinux64-1 has been undefined

virsh # quit

[root@fed18 ~]# virt-install --hvm --name OracleLinux64-1 --ram 2048 --vcpus 1 -f /dev/virtual-machines/OracleLinux64-1 --network bridge=br0 --cdrom /isos/Oracle_Linux_Release_6_Update_4_x86_64.iso --graphics vnc,listen=192.168.2.103,port=5901 --noautoconsole 
warning: failed to set locale, defaulting to C

Starting install...
Creating domain...                                                                                                                                          |    0 B  00:00:12     
Domain installation still in progress. You can reconnect to 
the console to complete the installation process.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.