Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using some audio utilities in Ubuntu 11.10 to tweak .mp3 files on my phone (Motorola Photon 4G). I connect via USB... both my phone and the internal SD card are mounted as two separate drives. The SD card has an unusual drive name with some odd characters.

When I'm finished, I unmount my phone (or "safely remove drive"), but the SD card can't be unmounted. I've mounted and unmounted my phone on 4 occasions now, and there are now 4 SD card drive icons that I can't remove from the desktop. I tried using the gconf-editor/apps/nautilus/desktop trick to make drives invisible and it's not working. Right-clicking on the icons and selecting "unmount" produced the following error message;

(I can't type the unusual drive name characters... replaced with xxx)

Unable to unmount xxx
umount: /media/xxx is not mounted (according to mtab)

How can I remove the unwanted icons from the desktop and is there a method for avoiding this problem in the future? Thanks!

share|improve this question
    
Try unity --reset –  izx Jul 5 '12 at 20:54
add comment

1 Answer 1

Method 1

Install Ubuntu Tweak

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Under Desktop > Desktop Icon Setting, choose to hide or show desktop icons.

Method 2

Install gconf

sudo apt-get install

Run it by pressing Alt+F2 and type this gconf-editor

In the Configuration editor, go to apps > nautilus > desktop. Untick the box that corresponds to the icons you'd like to hide.

To hide all desktop icons, go to apps > nautilus > preferences, look for show_desktop and untick the box.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.