Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I had a problem with the update-manager and search for a solution. On my search I found a post, where someone had the same problem and as solution they told him he should run this command on the terminal:

sudo rm /var/lib/apt/lists/*

I also run this, and the update-manager worked again. But now, I noticed that apt-get won't install anything. I wanted to install rvm (for ruby) and therefore I needed a few packages (build-essential and curl to be precise). But if I tried to install them, I always get the message that there is no installcandidate for that package... . What can I do to get apt-get working again?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You deleted apt-get's list of available packages, so it thinks that no packages exist and it is alone in this world :)

Just run sudo apt-get update to repopulate the lists, and then sudo apt-get install ... will work again.

share|improve this answer
    
I've done this, but nothing is changeing... . During the update, I got the message, that it couldn't find quite a few addresses. (e.g. de.archive.ubuntu.com/ubuntu/dists/precise-backports/universe/… 404 Not Found [IP: 141.30.13.20 80]) May this be the reason? If so, what can I do to get those hosts working? –  Gernot Jul 5 '12 at 20:48
    
The 404s are occurring because apt-get is trying to find uncompressed Packages lists at the mirror when only compressed Packages.bz2/gz are available. Please run Software Center, Edit Preferences, and change your mirror to the default Main Server, and try again. If that doesn't work, can you copy and paste the output of apt-config dump please? –  izx Jul 5 '12 at 20:51
    
Thanks a lot, that is working. I've changed the preferences and now I need to update a lot of packages. So, I guess, after the update is complete, apt-get will find my packages. Thx again :-) –  Gernot Jul 5 '12 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.