Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Wireshark 1.6 on Ubuntu Lucid Lynx from PPA (n-muench/programs-ppa2).
The libwsutil1 version is named 1.6.0-1~ppa1 so it should satisfy libwiretap1 dependency that needs version 1.6.0-1 ;
But it doesn't !!
I tried this:

sudo apt-get install libwiretap1

And this:

sudo apt-get -fm install libwiretap1

Both responded this:

The following packages have unmet dependencies:
  libwiretap1: Depends: libwsutil1 (>= 1.6.0-1) but 1.6.0-1~ppa1 is to be installed
E: Broken packages

(Notice that the ~ppa1 postfix seems to be the problem!)

What can I do?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

The -1~ppa1 tells the system that this isnt -1, but rather a version that will be overridden by -1. This therefore is not an issue with "version check", nor is it a mistake, it's by design. The special ~ symbol in the version means "This version does not supercede version -1 of the same package, and may be superceded by version -1 of the package, or by a later upstream version release that gets packaged."

To do this, with the PPA, the version you see in that number would need to be 1.6.0-1 (within the PPA) in order for the system to recognize it as 1.6.0-1.

This is why packages such as PHP 5 release candidates get overridden when a stable release comes out (php 5.4.0-1~rc3 vs. php 5.4.0-1, where the rc3 is a release candidate and the non-rc3 is the stable)

share|improve this answer
    
But a problem: both libwiretap1 and its dependency libwsutil1 are from same PPA so both have "-1~ppa1" so they should work with eachother while they don't! it seems libwiretap1 that has -1~ppa1 itself, depends on pure -1 verson of libwsutil1! Can I do something to fix this or I need find another PPA? –  4r1y4n Jul 5 '12 at 19:46
    
@4r1y4n that's because they didnt configure the packages correctly within the debian/control file of the PPA's packages. You'll need to either poke the creator of the PPA, and tell them to update both debian/control files' dependency lines to say: [package] (>=1.6.0-1~ppa1), where [package] is the package name (whether its libwiretap1 or libwsutil1, such as in libwiretap1's debian/control, [package] is libwsutil1), or find another PPA with correctly configured packages. –  Thomas W. Jul 6 '12 at 13:21
    
@4r1y4n (ran out of space) Normally someone packaging programs would make sure the debian/control files wouldnt break like this, especially if they tack on the ~ppa# suffix (you should see my PPAs, if they depend on eachother as a version, they're set correctly before I upload to a PPA, but hey, i'm a packager, its a habit i check everything before making a PPA public, or "production stable" so to speak) –  Thomas W. Jul 6 '12 at 13:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.