Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this crappy HP Pavilion G6 laptop (no other choice, provided by office) which is having troubles dealing with graphics (Ubuntu 12.04 LTS).

Details of the machine:
Its having a ATI Radeon graphics card, and I feel it is the main culprit.

I also had troubles installing it and only after following this link, I could install it.
(setting nomodeset in GRUB)

Now startup works good, but many things related to graphics don't. (I installed Cinnamon too, but it also doesn't seem to work correctly) I have all the updates applied.

I am currently facing problems in starting Android emulator to test my Android apps.
Whenever I try to start the emulator, I get following error message:

Starting emulator for AVD 'Phone_41'
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12

Apart from this, many other graphic related things do not work (Window switcher in graphic mode, Cinnamon)

If I head to Settings>Drivers I see two graphics drivers for the card being displayed:

enter image description here

The post-release-updates don't get installed and mess with the other one too (the one which is showing that it requires a restart)

Problems:

  • Graphic Drivers can't be installed
  • Android Emulator doesn't start, throws the above errors (maybe because of the graphics)

Is it a known issue or is there any workaround for this?

share|improve this question
    
Im having trouble undertsanding what your bottom-line question is here. Is it to fix your graphics or having the ability to start Android Emulator? Please consider editing you question to be more specific. As a starting point, the fact that you are suing 12.04, I think the instructions you used to install your ATI drivers are out dated. Have a look at this Q&A askubuntu.com/questions/124292/… –  Stephen Myall Jul 5 '12 at 8:28
    
Sorry for creating the confusion, I have edited the question, I hope its less confusing now. I am going through that link. Will I have to reinstall 12.04 all over again for the drivers? –  Sheikh Aman Jul 5 '12 at 9:40
    
No you dont have to reinstall 12.04 all over again but you may have to purge your current ATI driver installation. In the link you are looking In the question stem there is link to an older question, the instructions for purging are there, good luck –  Stephen Myall Jul 5 '12 at 9:47
    
Good, Lord! I am just going to do what it says. Thanks a lot! :) –  Sheikh Aman Jul 5 '12 at 9:58
    
You can't install the post-release-update driver now. It's a bug and will be fixed sonner or later. –  Emerson Hsieh Jul 5 '12 at 10:35
show 1 more comment

6 Answers

First things first Your Graphics Card

The link presented in your question contains outdated instructions to correctly install ATI graphics drivers for 12.04. You need to purge this installation and reinstall the coorect graphics driver (ensuring you all meet all the correct dependencies). This may also be the cause of Cinnamon not working (but if it il doesnt work you can ask a new question here).

Hopefully some else has knowledge about the Android Emulator (not a strong subject with me) but lets get you system stable first

Instructions on how to install your graphics driver can be found here

share|improve this answer
    
I followed everything that you said on the link, and it still doesn't work :( I feel this link: wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide also says the same thing, but it just won't work. fglrxinfo says Bad Request and a few more errors and error codes. I have ATI Radeon HD 7450M card (found on HP website) and sudo amdccle pops up an error notification saying AMD drivers are not installed –  Sheikh Aman Jul 9 '12 at 5:51
    
I installed Ubuntu on my Samsung laptop yesterday along with its Bumblebee driver for Nvidia card, and it all worked like a charm. But no success with this HP laptop :-/ –  Sheikh Aman Jul 9 '12 at 5:52
    
I just recalled that I have GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" set in /etc/default/grub Can this line be stopping the drivers to come into effect? –  Sheikh Aman Jul 18 '12 at 6:24
    
I tried removing nomodeset from grub during boot, and it again gives me a black screen after boot –  Sheikh Aman Jul 18 '12 at 6:33
add comment

I have had the exact same problem. I have: -Followed all the links. -Installed all the libraries. -Uninstalled/reinstalled, sudo aticonfig --initial=dual-head, ... nothing helpful.

My advice, although not very helpful, is to make a new installation on a computer that already has drivers available. Build a computer with known working components that have the software to support it. Otherwise I will keep my eye on this link for something USEFUL.

share|improve this answer
    
I have only this computer with me, and have no options but to use this one only for office purposes :( –  Sheikh Aman Jul 18 '12 at 10:12
add comment

Sometimes I have to bother on certain systems when installing ATI graphics using Additional Drivers. To fix this, I open a terminal and type:

sudo apt-get install fglrx
share|improve this answer
    
for me, it says fglrx is already the newest version –  Sheikh Aman Jul 18 '12 at 7:14
    
I tried reinstalling it, and then received errors during boot that your system is running in low graphic mode. I repaired and switched back to the default version to make it work. –  Sheikh Aman Jul 18 '12 at 10:13
add comment

I am also using HP pavillion g6-1302tx, i have followed the following link to install the graphic drivers on my laptop.

http://www.upubuntu.com/2012/03/how-to-install-ati-amd-catalyst-122.html

Blank screen at the booting time is still an issue. Well setting nomodeset option abruptly increased the brightness of the screen and the brightness adjustment keys stopped responding; so it's better not to use nomodeset option.

Hope this is helpful.

share|improve this answer
    
So if we don't use nomodeset then how else will that blank screen issue is resolved? –  Sheikh Aman Jul 19 '12 at 9:50
    
Surprisingly, I do get till the point where I am given this wizard, but then the wizard doesn't display any text. What I see is this: i.imgur.com/vVIPz.png –  Sheikh Aman Jul 19 '12 at 10:16
    
well I use the brightness keys for now. –  Ankit Jul 19 '12 at 10:26
    
Brightness is not a problem as of now. getting the drivers to work is. Did you see that image I posted above? –  Sheikh Aman Jul 19 '12 at 10:33
    
alright; i tried nomodeset at the time 12.04 was released; brightness was an issue then. Either the link i posted earlier or this askubuntu.com/questions/124292/… might help you with the graphic drivers. You have to install it manually, i guess. –  Ankit Jul 19 '12 at 10:44
show 3 more comments

I just dealt with the the same issue on my system (Though mine is a desktop) Go to the ATI website and grab the driver for "Linux" operating systems. It should come in a .run format once you have it on a thumb drive or wherever you need to do some very basic things (Which aren't so basic to find on the Internet). First Place the .run file on your desktop (For simplicity) then rename it something short, sweet, and to the point (EX. GD.run) which stands for (Graphics Driver). Then once you get to that point you need to shutdown "X" server before attempting to install. I assume you already know how to do this but in the case that you don't I will clarify because this is also not so straight forward on the Internet. So to shutdown "X" server you need to open terminal and run this command

sudo /etc/init.d/lightdm stop

sometimes that one fails to stop the "X" server so try this one. To check if it fails simply do the remainder of the steps and it will tell you whether the "X" server is still running.

sudo /etc/init.d/gdm stop

Then you need to press CTRL+ALT+F1 and then enter the following. (Here comes the part why I told you to put it onto the desktop and name it something simple and easy to remember.)

Enter Login Credentials
cd ~/Desktop 
chmod +x GD.run
sudo ./gd.run

Then simply follow the steps given by the driver. Then to leave the black screen CTRL+ALT+F7 After that point it is a matter of going to the Catalyst Manager and setting it up.

share|improve this answer
    
That really had set my hopes high ;-) I could install the drivers in command line mode and the driver was installed successfully. However, the black screen issue was still present (The laptop screen doesn't seem to be lit at all), for which I had to put nomodeset in grub to boot. but once the system boots up, it says its running in low graphics & I'll have to reconfigure the graphics, and somehow I can't go past that screen. Weird. Would you want any screenshot/video? –  Sheikh Aman Jul 23 '12 at 16:51
    
@Mathew any other suggestions? –  Sheikh Aman Jul 24 '12 at 8:00
add comment

You seems to have 2 problem at the same time:

  • a problem with the drivers of your graphic card, in this case i suggest to take a look at http://wiki.cchtml.com/index.php/Main_Page which is a good place to start and remember to uninstall everything that is old before installing something new
  • a problem with your android environment, and in this case you probably are messing up with the Mesa library that is the OpenGL implementation used by the Android emulator, just take a look at how to setup your OS for Android development http://source.android.com/source/initializing.html
share|improve this answer
    
-1 Neither of these points are a solution to the issue presented there fore should be comments not answers. You have just stated you understand the issues and provided links (which may or may not be useful) but you do not definitely state that these will fix these issues. please edit and improve the quality of your answer. –  Stephen Myall Jul 5 '12 at 10:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.