Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Tried to boot Ubuntu, but something like this shows up instead:

screen showing grub> prompt

share|improve this question
did you installed Ubuntu correctly? Have you ever booted your system after installation – Anwar Shah Jul 5 '12 at 6:59
Please indicate your BootInfo URL to provide more information about your system. – LovinBuntu Jul 5 '12 at 21:33

If you were able to boot Ubuntu in past, but not Now, Do this steps to solve the problem.

  • First type ls command and Press Enter to see all the available partitions. The entries will be shown as (hd0,msdos1) (hd0,msdos2) (hd0,msdos5) etc.

  • Then type ls (hd0,msdos1)/ to see the content of the drive. if you see entries like vmliuz or initrd, it is your Linux partition. If you fail with (hd0,msdos1), try with (hd0,msdos2) and so on, until you recognize your Ubuntu partition.

  • When you correctly identify your Ubuntu partition, type root=(hdX,msdosX) , replace the X with correct identified number. For example, if you see vmlinuz and initrd entries by entering ls (hd0,msdos5), the command will be root=(hd0,msdos5).

  • then type configfile /boot/grub/grub.cfg and type Enter. This will bring you Previous Ubuntu grub menu.

  • Then choose the entry to boot Ubuntu.

  • After you booted up, Open a terminal and type sudo update-grub and press Enter. This will update the grub menu and prevent future problems.

In the case, If You did not able to boot to Ubuntu after installation, re-installing Ubuntu is the best option. You can check this question.

share|improve this answer
No, I have never been able to boot. And this did not help. I've been having so many problems with Ubuntu... – KalebNoobMaster Jul 5 '12 at 12:22
Didn't work for me. After entering "configfile ..." it went back to the grub prompt, not the menu. – Vituel May 7 '15 at 11:54
You can try insmod normal. See if work, since this answer is for Grub-Legacy – Anwar Shah May 8 '15 at 15:31

I know this will sound irrelevant but after several restart attempts and before reading any posts, i decided to go to the bios in the scope of trying a restore defaults and / or change booting sequences. The problem was solved just by pressing F2 several times, including at the very moment Grub was supposed to start. I restarted a few times since then without any issues. My config is a dual booting with Ubuntu 12.04 & Windows 7

Hope it works for someone else

share|improve this answer

Disconnecting my Windows 7 drive fixed this.

share|improve this answer
I doubt that is applicable, desirable, or even possible in most circumstances. – David Foerster May 12 at 21:57
I tried the top answer, but did not see any files on the ubuntu drive. Also, it may be preferable to not change anything in the boot config if you can avoid it. – crizCraig May 13 at 20:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.