Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I recently upgraded from 11.10 to 12.04. My first attempt failed, and I received an error stating that not all of the required packages were downloaded. Before (successfully) attempting again, I noticed that there was no longer a networking indicator in the upper panel. The indicator did not reappear with the installation of 12.04.

To be clear, my wireless connection has experienced no problems, despite the missing indicator.

Here are the solutions that I have found which did not work for me:

  1. Editing /etc/NetworkManager/NetworkManager.conf and replacing [ifupdown] managed=false with =true.
  2. Reinstalling network-manager (via apt-get install --reinstall).

I am currently running 12.04 on an Asus Eee PC 1005 HA, and I am new to seeking solutions through forums, so I apologize if I have neglected to provide some vital information about my hardware.

share|improve this question

2 Answers 2

up vote 22 down vote accepted

Motivated by this post on, I have found a solution to my issue in two steps.

  1. Purge and reinstall network-manager-gnome:

    sudo apt-get purge network-manager-gnome && sudo apt-get install network-manager-gnome
  2. Add nm-applet to the Startup Applications (which may be found by entering "Startup Applications" in the Dash and setting the path to /usr/bin/nm-applet).

    I verified that the latter step was necessary, as the indicator did not appear after login without this addition of nm-applet to the Startup Applications.

share|improve this answer
thanks! finally learned the name of that applet! i installed network-indicator for some dumb reason, and it removed the network-manager-gnome... and i'm clueless to the unintuitive magic required to get apt-get removed package history... after reinstalling this one all is back to normal. Also, had to reboot before nm-applet stopped dying with errors. think it also installed some services, but i didn't take note. – gcb Jul 22 '12 at 5:13
Thank you! I have had several problems with WiFi and not it's working perfect (so far)! – Diego Jancic Oct 10 '12 at 21:20
Only needed to do the first step, then relog – panmari Jan 20 '13 at 16:46
Thanks! This also worked for me in Ubuntu 14.04. – Merri Jul 28 '14 at 20:58
Did not help on ubuntu 14.04 64bit – Dziamid Mar 17 at 11:06

if everything else fails,use this

sudo apt-get install indicator-applet-complete

quick restart and you should see it on the panel again

share|improve this answer
This helped me on Ubuntu 14.04 64bit – Dziamid Mar 17 at 11:05

protected by Community Nov 4 at 4:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.