Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Dual-booting Windows 7 and Ubuntu 12.04 LTS.

I went to reboot from Win to Ubu, and found a few interesting things.

My POST screen is covered in blocks of epileptic colors until I hit GRUB, which continues when I try to boot into Ubuntu. These color blocks don't appear when I use my on-board VGA, so I'll just attribute to that.

Grub dimensions are swapped (card vs onboard, probably), but, when interfacing with onboard VGA, the Grub Timeout Counter works and when using my card, it does not (see "[!!!]" below for more information)

Booting into Ubuntu directly causes the error:

SP5100 TCO timer: mmio address 0xfec000f0 already in use

Booting into recovery mode, meanwhile, and then "resuming normal boot" gets me to the desktop without native 1440x900 resolution and graphic drivers can't tell the monitor it's looking at (I assume this is because it's not a full graphic boot, and as it says, some drivers won't run?) [!!!] When I reboot after going into recovery mode, the countdown timer works ONCE, puts me back into default ubuntu boot, and then does not work again until after another recovery-mode boot.

Windows 7 can boot perfectly with no issues whatsoever from epilepsy color blocks or driver detection. This makes me wonder /why/ the POST screen can't handle my video card anymore.

Amidst all the diagnostics, I opened my case and re-seated the videocard securely, ensuring it wasn't a loose connection-- But this did nothing to help me.

Hardware
I am running an NVidia GeForce GTX 8800 video card in a PCI slot. I have 4.8GiB memory, an AMD Athlon II Quad-core 640 Processor, on an MSI K9N6GM Series Mobo. Onboard video is an NVidia GeForce MCP61(V/S/P) card.

Note: I did not have any of these problems yesterday, and I have been using Ubuntu intensively for a week, though it's been working flawlessly for months. I've recently been using it to mod my Android phone, perhaps I messed something up in the file system?

share|improve this question

closed as off topic by Eliah Kagan, Luis Alvarado, Tom Brossman, hhlp, Jorge Castro Jan 6 '13 at 15:39

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is a bug. If you don't believe the existing bug report covers it, you could reporting a new bug. (This question also has some good information about bug reporting.) This will probably be closed as off-topic, in accordance with the FAQ and this policy. –  Eliah Kagan Jan 6 '13 at 2:27
    
Thank you for your post, as of today actually, I fixed my issue. I did two things in one step, so either may have worked individually. First, I upgraded my graphics drivers with sudo apt-get install nvidia current, then upgraded from 12.04 LTS to 12.10, which allowed me to resume full graphical boot. Haha! –  jwarner112 Jan 7 '13 at 3:24
    
I'm glad it got fixed. If you believe the problem you experienced is the same as described in any existing bug report (for example, if you believe it's the same as the problem here), you may want to comment in the bug to report what worked for you. This may benefit other users. (Of course, you should look through the bug report and existing comments in case it's already been reported as a workaround.) –  Eliah Kagan Jan 7 '13 at 4:08

2 Answers 2

It's a bug. Take a look at https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1055096 and add your information there.

share|improve this answer

That happened to me once in 12.04 after the kernel upgrade to 3.5. Booting from the older kernel version enabled me to work around the problem. (If you don't see a menu when you boot up that lets you choose older kernels, hold down the Shift key as your machine starts.)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.