Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Graphics Card: NVidia 460 GTX.

Driver: NVIDIA accelerated graphics driver (version current)

I have one DVI monitor, an old Dell LCD from 2005, and one VGA monitor, an Asus ML238H from 2010 whose HDMI port broke. The Asus is plugged into my graphics card's primary monitor slot and is the better monitor even though it is VGA but my computer defaults to the Dell. This happens when I boot as well; the loading screens, the motherboard brand image, etc. are all displayed on the Dell monitor until Windows loads. Then both monitors work.

The same thing happened when I booted up Ubuntu 12.04 but I did not see the second monitor when the log-in screen popped up, nor did I when I logged in. I went to System Settings/Displays and my Asus monitor is not an option. I clicked Detect Displays and the Asus is not detected.

I looked at the other questions regarding NVIDIA drivers and recalled my problems with Ubuntu a few years ago and decided to check the driver. I went to Additional Drivers to install the proprietary driver and it looks like it's installed and active but I'm still having this problem. There is another driver option, the post-release NVIDIA driver, but that does not fix the problem either.

Also, under System Details/Graphics the graphics device is listed as Unknown, which might indicate that it is using an open source generic driver and not the proprietary NVidia driver. But under Additional Drivers it says that I am using the NVidia driver.

Any help is appreciated.

share|improve this question
    
I had the same problem with ubuntu 12.04LTS –  Pranit Bauva Sep 12 '12 at 16:21
add comment

2 Answers

Get the stable driver by opening a terminal and typing sudo nvidia-setting

Here you can configure multiple displays and your gpu

Note: If you do not sudo into it you settings will be lost when you leave the gui

share|improve this answer
    
Thanks, that worked. And thanks for telling me to not use the GUI directly. I didn't even know that there is an Nvidia driver GUI. 12.4 needs a start menu that lets you see all the programs, honestly. It's a shame that we still have to use the command line in 2012. I guess this time it's Nvidia's fault for not programming the GUI to prompt for the password to give root access, but stuff like this really turns people away from Linux. :/ –  JaneGoodall Jul 5 '12 at 4:59
    
Most linux programs need you cant even install a new theme with out root access never mind edit important files. –  mark kirby Jul 5 '12 at 15:30
    
But you must also realise that the sudo protocall is the reson for a secure viruse free environment and if you learn the terminal thing run like twice as fast cos your cpu dosent have to draw graphics and your ram dose not have to store them. –  mark kirby Jul 5 '12 at 15:32
add comment

You should try the "NVIDIA X Server Settings" window. Go to your "Dash Home" button and type in "nvidia" (without the quotes) in the search, it should then come up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.