Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.04 in a Intel Ivy Bridge with integrated graphics and NVidia GPU with Optimus tech, however i cant manage it to work properly. I have already passed by the solution of bumblebee project, however iam got the following message when try to run anything with nvidia card( e.g. with optirun firefox):

[ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ERROR]Could not connect to bumblebee daemon - is it running?

Since the nvidia card is not working properly, some softwares like Scilab, that make use of X11 system for graphic handling and plotting, wont work too.

my bios has no option concerning graphics card and the log of daemon returned:

Jul 5 16:10:51 humannoise-W251ESQ-W270ESQ bumblebeed[980]: Module 'nvidia' is not found. 
Jul 5 16:10:51 humannoise-W251ESQ-W270ESQ kernel: [ 17.943272] init: bumblebeed main process (980) terminated with status 1 
Jul 5 16:10:51 humannoise-W251ESQ-W270ESQ kernel: [ 17.943288] init: bumblebeed main process ended, respawning 
Jul 5 16:10:51 humannoise-W251ESQ-W270ESQ bumblebeed[1026]: Module 'nvidia' is not found.

The lspci -nn | grep '\[030[02]\]:' returned:

00:02.0 VGA compatible controller [0300]: Intel Corporation Ivy Bridge Graphics Controller [8086:0166] (rev 09)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:0de9] (rev a1)

Ok, for the command dpkg -l | grep '^ii' | grep nvidia i got :

ii  bumblebee-nvidia                       3.0-2~preciseppa1                         nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-current                         302.17-0ubuntu1~precise~xup1            NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-current-updates                 295.49-0ubuntu0.1                       NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                        302.17-0ubuntu1~precise~xup3            Tool of configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                295.33-0ubuntu1                         Tool of configuring the NVIDIA graphics driver

After full reinstallation, including the remove of any previous nvidia drive, lsmod | grep -E 'nvidia|nouveau' returned:

nvidia              10888310  46

dmesg | grep -C3 -E 'nouveau|NVRM' returned things like:

[ 1875.607283] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1875.607289] nvidia 0000:01:00.0: setting latency timer to 64
[ 1875.607293] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[ 1875.607363] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  302.17  Tue Jun 12 16:03:22 PDT 2012
[ 1884.830035] nvidia 0000:01:00.0: PCI INT A disabled
[ 1884.832058] bbswitch: disabling discrete graphics
[ 1884.832960] bbswitch: Result of Optimus _DSM call: 09000019

Some programs, like Scilab, are now working fine under optirun(e.g. >optirun scilab) call.

share|improve this question
    
you need to restart the system. –  Web-E Jul 5 '12 at 4:32

2 Answers 2

up vote 4 down vote accepted

The error "Could not connect to bumblebee daemon - is it running?" means that the Bumblebee daemon refused/ failed to start.

In your case, "Module 'nvidia' is not found.". This means that the Nvidia kernel driver has not properly been installed. Make sure that you install the linux-headers-generic package and reinstall the nvidia package:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall nvidia-current

It could also occur if your system is not detected as an Optimus laptop which has two graphics card, an Intel and a Nvidia one. Check your /var/log/syslog file for messages from "bumblebeed" (the Bumblebee daemon):

grep bumblebeed /var/log/syslog

If the message is No nVidia graphics card found, quitting., then your laptop has no Nvidia chip or it is disabled in BIOS. The message No Optimus system detected, quitting. is shown when the Intel graphics card cannot be found. In either case, check the BIOS settings for an "Optimus mode / integrated only / discrete only" option (or: "detect Optimus).

The output of the command lspci -nn | grep '\[030[02]\]: should look like:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 425M] [10de:0df0] (rev ff)

share|improve this answer
    
@Humannoise Strange, installing bumblebee should also pull the nvidia-current package. What does dmesg | grep -C3 -E 'nouveau|NVRM' and lsmod | grep -E 'nvidia|nouveau' yield? You can add it to your question. –  Lekensteyn Jul 5 '12 at 21:14
    
empty return to nouveau commands –  Humannoise Jul 5 '12 at 21:37
    
Can you add dpkg -l | grep '^ii' | grep nvidia to your question? You did not add lsmod | grep ... to your question, was it empty? –  Lekensteyn Jul 5 '12 at 21:50
    
yes it was empty, both commands –  Humannoise Jul 6 '12 at 0:12
    
Did you actually install Bumblebee as described at wiki.ubuntu.com/Bumblebee? –  Lekensteyn Jul 6 '12 at 9:49

I encountered this issue after upgrading some of my packages. It seems the problem was caused by the Nvidia kernel module being renamed from "nvidia" to "nvidia_current".

If you have the nvidia-current package installed, you can fix the issue by editing /etc/bumblebee/bumblebee.conf and setting the following values:

...
[bumblebeed]
Driver=nvidia
...
[driver-nvidia]
KernelDriver=nvidia_current
Module=nvidia
...

Then restart bumblebee:

sudo service bumblebeed restart

And test:

optirun glxgears

References:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.