Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading to Mythbunu 12.04 and Mythtv 0.25, my playback has been showing tearing and also the Unity top panel plus the Unity Launcher overlay the screen.

Is there a way to fix this?

share|improve this question

2 Answers 2

You might want to consider openbox.

It's a bit hacky to set up, and not as "cool" as unity, but you can get a very low-resource desktop with all the important features, like application indicators

For a very basic, but full-featured desktop:

sudo apt-get install openbox lxpanel lxpanel-indicator-applet-plugin obconf lxpappearance

This will pull in some gtk2 packages and other dependencies, but not too much.

Also, gedit does make a backup. It makes a new file with a tilde; ie xorg.conf~ Be aware, each time you save a file this backup will be overwritten with a new backup.

share|improve this answer
    
Thanks for the advice. One of the blessings of Ubuntu(Mythbuntu) is that it works out of the box (at least until lately). This is for 2 HTPC's that basically do nothing but Mythtv, and my goal is to do the absolute minimum of maintenance and changes from default. For my major work I have abandoned Ubuntu for Arch Linux ⋯ where everything is custom and using terminal is essential ‧ but everything works ‧ especially the tools I use every day. ------- You are right about gedit, although not mentioned on the man page it does automatically produce a backup appended with "~". –  keepitsimpleengineer Jul 16 '12 at 15:23
up vote 0 down vote accepted

After trying some suggestions about turning off compositing, I finally discovered how to do it so it stays off.

Note this only works for Mythtv or for a desktop where you don't need or want compositing, and uses nvidia (as far as I know).

First, run Unity in 2D ⋯ this makes the Unity stuff overlaying the playback go away.

To do this, when you log on, press the gear like button on the login screen and select Unity 2D. If you bypass the startup login, you can log out and then to this when you log back in.

Second, turn off compositing in the xorg.conf file.

This is how:

Open a terminal and type in…

sudo nano -B /etc/X11/xorg.conf

The move the pointer to the end of the file and type in these three lines:

Section "Extensions"
    Option "Composite" "Disable"
EndSection

Ctrl-O and <enter> to save the changes, then Ctrl-X to close. Note that with the -B option, nano will save a backup copy as xorg.conf~

Then restart the X server or reboot.

If you are nervous about using the terminal to edit, you can use the text editor, gedit.

Open a terminal and type in gksu gedit. After putting in your password, you can edit system files, Be careful...!

Use the open command to open Filesystem: /etc/X11/xorg.conf and add the lines to the bottom of the file. Update: gedit does make a "~" appended backup file

Now, enjoy your Mythtv...!


If there is still tearing, one more thing you can do...

Edit your xorg.conf as above, this time adding a line at the end of the Section "Device"

Add this line:

    Option         "TripleBuffer" "1"

It now should look a lot like my HTPC xorg.conf file:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "unix/:7100"
EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SAMSUNG"
    HorizSync       26.0 - 81.0
    VertRefresh     24.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
    Option         "TripleBuffer" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Disable"
EndSection

Good luck...!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.